commit a636c342d6c6cd382a6e51edf737f228590f0c48
parent ca12869ef10f8515065132618df4046cadd35feb
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 21 May 2023 11:25:01 +0400
Move libcpr to nixpkgs
Diffstat:
4 files changed, 4 insertions(+), 39 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -325,7 +325,6 @@ lib.makeScope newScope (
};
capture2text = libsForQt5.callPackage ./misc/capture2text { };
cfiles = callPackage ./misc/cfiles { };
- cpr = callPackage ./misc/cpr { };
csvquote = callPackage ./misc/csvquote { };
csvtools = callPackage ./misc/csvtools { };
didder = callPackage ./misc/didder { };
diff --git a/pkgs/misc/cpr/default.nix b/pkgs/misc/cpr/default.nix
@@ -1,34 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, cmake, curl }:
-
-stdenv.mkDerivation (finalAttrs: {
- pname = "cpr";
- version = "1.10.2";
-
- src = fetchFromGitHub {
- owner = "libcpr";
- repo = "cpr";
- rev = finalAttrs.version;
- hash = "sha256-F+ZIyFwWHn2AcVnKOaRlB7DjZzfmn8Iat/m3uknC8uA=";
- };
-
- postPatch = ''
- substituteInPlace include/CMakeLists.txt \
- --replace "target_link_libraries(cpr PUBLIC stdc++fs)" ""
- '';
-
- nativeBuildInputs = [ cmake ];
-
- propagatedBuildInputs = [ curl ];
-
- cmakeFlags = [
- "-DCPR_USE_SYSTEM_CURL=ON"
- ];
-
- meta = with lib; {
- description = "Simple C++ wrapper around libcurl";
- inherit (finalAttrs.src.meta) homepage;
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-})
diff --git a/pkgs/mqtt/influxdb-cxx/default.nix b/pkgs/mqtt/influxdb-cxx/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchFromGitHub, cmake, cpr, boost, catch2, trompeloeil }:
+{ lib, stdenv, fetchFromGitHub, cmake, libcpr, boost, catch2, trompeloeil }:
stdenv.mkDerivation (finalAttrs: {
pname = "influxdb-cxx";
@@ -13,7 +13,7 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs = [ cmake ];
- buildInputs = [ cpr boost ]
+ buildInputs = [ libcpr boost ]
++ lib.optionals finalAttrs.doCheck [ catch2 trompeloeil ];
cmakeFlags = [
diff --git a/pkgs/mqtt/mqtt-to-influxdb/default.nix b/pkgs/mqtt/mqtt-to-influxdb/default.nix
@@ -4,7 +4,7 @@
, cmake
, spdlog
, libyamlcpp
-, cpr
+, libcpr
, cxxopts
, nlohmann_json
, influxdb-cxx
@@ -42,7 +42,7 @@ stdenv.mkDerivation (finalAttrs: {
buildInputs = [
spdlog
libyamlcpp
- cpr
+ libcpr
cxxopts
nlohmann_json
influxdb-cxx