commit ca12869ef10f8515065132618df4046cadd35feb
parent ea54f5220751b682883bdbdfc25ec963e237c90d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 21 May 2023 11:08:42 +0400
Move scooby to nixpkgs
Diffstat:
4 files changed, 2 insertions(+), 26 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -230,7 +230,6 @@ lib.makeScope newScope (
rio-stac = callPackage ./geospatial/rio-stac { };
rio-tiler = callPackage ./geospatial/rio-tiler { };
sasplanet-bin = callPackage ./geospatial/sasplanet/bin.nix { };
- scooby = callPackage ./geospatial/scooby { };
server-thread = callPackage ./geospatial/server-thread { };
starlette-cramjam = callPackage ./geospatial/starlette-cramjam { };
supermercado = callPackage ./geospatial/supermercado { };
diff --git a/pkgs/geospatial/localtileserver/default.nix b/pkgs/geospatial/localtileserver/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3Packages, fetchFromGitHub, large-image-source-gdal, server-thread, scooby }:
+{ lib, python3Packages, fetchFromGitHub, large-image-source-gdal, server-thread }:
python3Packages.buildPythonApplication rec {
pname = "localtileserver";
diff --git a/pkgs/geospatial/scooby/default.nix b/pkgs/geospatial/scooby/default.nix
@@ -1,23 +0,0 @@
-{ lib, python3Packages, fetchFromGitHub }:
-
-python3Packages.buildPythonPackage rec {
- pname = "scooby";
- version = "0.7.2";
- format = "pyproject";
-
- src = fetchFromGitHub {
- owner = "banesullivan";
- repo = "scooby";
- rev = "v${version}";
- hash = "sha256-eY8Ysc20Q1OHKb/LU+4gqnSgNfHCytjOnnvB24EfQto=";
- };
-
- propagatedBuildInputs = with python3Packages; [ setuptools ];
-
- meta = with lib; {
- description = "Great Dane turned Python environment detective";
- inherit (src.meta) homepage;
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- };
-}
diff --git a/pkgs/geospatial/server-thread/default.nix b/pkgs/geospatial/server-thread/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3Packages, fetchFromGitHub, scooby }:
+{ lib, python3Packages, fetchFromGitHub }:
python3Packages.buildPythonPackage rec {
pname = "server-thread";