commit fe1797e6c9acc3a40db15905ca5a04a1f01f8438
parent 1b58992a3182064e241c2778ae4c120a89719b00
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 16 Jun 2023 21:27:05 +0400
Add mproxy
Diffstat:
2 files changed, 29 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -390,6 +390,7 @@ lib.makeScope newScope (
ioxy = callPackage ./mqtt/ioxy { };
janus-mqtt-proxy = callPackage ./mqtt/janus-mqtt-proxy { };
mongoose = callPackage ./mqtt/mongoose { };
+ mproxy = callPackage ./mqtt/mproxy { };
mqtt-benchmark = callPackage ./mqtt/mqtt-benchmark { };
mqtt-cli = callPackage ./mqtt/mqtt-cli { };
mqtt-explorer = callPackage ./mqtt/mqtt-explorer { };
diff --git a/pkgs/mqtt/mproxy/default.nix b/pkgs/mqtt/mproxy/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, lib, fetchFromGitHub, buildGoModule }:
+
+buildGoModule rec {
+ pname = "mproxy";
+ version = "0.3.0";
+
+ src = fetchFromGitHub {
+ owner = "mainflux";
+ repo = "mproxy";
+ rev = "v${version}";
+ hash = "sha256-gjFAuYDOFslhfDN+uWY3RZroUDrMERvBGi+gTtl4eLo=";
+ };
+
+ vendorHash = null;
+
+ postInstall = ''
+ mv $out/bin/{cmd,mproxy}
+ mv $out/bin/{client,mproxy-client}
+ '';
+
+ meta = with lib; {
+ description = "MQTT proxy";
+ inherit (src.meta) homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}