commit 1b58992a3182064e241c2778ae4c120a89719b00
parent d188782baf2c8992c38fafa221c57fe8e824b0ea
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 16 Jun 2023 21:19:53 +0400
Add mqtt-proxy
Diffstat:
2 files changed, 28 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -393,6 +393,7 @@ lib.makeScope newScope (
mqtt-benchmark = callPackage ./mqtt/mqtt-benchmark { };
mqtt-cli = callPackage ./mqtt/mqtt-cli { };
mqtt-explorer = callPackage ./mqtt/mqtt-explorer { };
+ mqtt-proxy = callPackage ./mqtt/mqtt-proxy { };
mqtt-to-influxdb = callPackage ./mqtt/mqtt-to-influxdb { };
mqtt-to-influxdb-forwarder = callPackage ./mqtt/mqtt-to-influxdb-forwarder { };
nanosdk = callPackage ./mqtt/nanosdk { };
diff --git a/pkgs/mqtt/mqtt-proxy/default.nix b/pkgs/mqtt/mqtt-proxy/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, lib, fetchFromGitHub, buildGoModule, cyrus_sasl }:
+
+buildGoModule rec {
+ pname = "mqtt-proxy";
+ version = "0.5.0";
+
+ src = fetchFromGitHub {
+ owner = "grepplabs";
+ repo = "mqtt-proxy";
+ rev = "v${version}";
+ hash = "sha256-odSVoBBjg4TGP5Jw+7p9+kTBR2JP1ZJUKR3lBcOjK4g=";
+ };
+
+ vendorHash = null;
+
+ buildInputs = [ cyrus_sasl ];
+
+ ldflags = [ "-X github.com/prometheus/common/version.Version=${version}" ];
+
+ meta = with lib; {
+ description = "MQTT Proxy allows MQTT clients to send messages to other messaging systems";
+ inherit (src.meta) homepage;
+ #license = licenses.cc-by-nc-nd-40;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}