commit f992142ea5c81f39e05cc366d8448962bb532119
parent c842dca5a5f381f2ea0ae82b741e6fc2ac70e7ac
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 29 Dec 2019 04:01:56 +0300
Add gpxelevations
Diffstat:
3 files changed, 38 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -33,6 +33,10 @@ in rec {
gpx-layer = perlPackages.callPackage ./pkgs/gpx-layer {
inherit (sources) gpx-layer;
};
+ gpxelevations = python3Packages.callPackage ./pkgs/gpxelevations {
+ inherit gpxpy;
+ inherit (sources) gpxelevations;
+ };
gpxlab = libsForQt5.callPackage ./pkgs/gpxlab {
inherit (sources) GPXLab;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -107,6 +107,18 @@
"url": "https://github.com/ericfischer/gpx-layer/archive/746b4723cf1f69fb86d45cf2d4efeaae9e711d2d.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "gpxelevations": {
+ "branch": "master",
+ "description": "Geo elevation data parser for \"The Shuttle Radar Topography Mission\" data",
+ "homepage": "",
+ "owner": "tkrajina",
+ "repo": "srtm.py",
+ "rev": "075126875bedbee0f23676f4a8159c6240398a95",
+ "sha256": "0yya7y5vkya6aqq338jwxry71yhywyjnb67nxvplq69nadzy0vn0",
+ "type": "tarball",
+ "url": "https://github.com/tkrajina/srtm.py/archive/075126875bedbee0f23676f4a8159c6240398a95.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"gpxpy": {
"branch": "master",
"description": "gpx-py is a python GPX parser. GPX (GPS eXchange Format) is an XML based file format for GPS tracks.",
diff --git a/pkgs/gpxelevations/default.nix b/pkgs/gpxelevations/default.nix
@@ -0,0 +1,22 @@
+{ lib, buildPythonApplication, python, requests, gpxpy, gpxelevations }:
+
+buildPythonApplication rec {
+ pname = "gpxelevations";
+ version = lib.substring 0 7 src.rev;
+ src = gpxelevations;
+
+ propagatedBuildInputs = [ requests gpxpy ];
+
+ doCheck = false;
+ #checkPhase = ''
+ # ${python.interpreter} -m unittest test
+ #'';
+
+ meta = with lib; {
+ description = gpxelevations.description;
+ homepage = "https://github.com/tkrajina/srtm.py";
+ license = licenses.asl20;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ sikmir ];
+ };
+}