commit c842dca5a5f381f2ea0ae82b741e6fc2ac70e7ac
parent 1789cddb86b0e2bd0982765ae02c5b6feff5e614
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 28 Dec 2019 18:58:52 +0300
Add imgp
Diffstat:
3 files changed, 37 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -57,6 +57,9 @@ in rec {
gt4gd = python3Packages.callPackage ./pkgs/gt4gd {
inherit (sources) google-translate-for-goldendict;
};
+ imgp = python3Packages.callPackage ./pkgs/imgp {
+ inherit (sources) imgp;
+ };
mbtileserver = callPackage ./pkgs/mbtileserver {
inherit (sources) mbtileserver;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -131,6 +131,18 @@
"url": "https://notabug.org/irdvo/gpxtools/archive/b989f357abb9f9b694cbe95081dd8d1094019233.tar.gz",
"url_template": "https://notabug.org/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "imgp": {
+ "branch": "master",
+ "description": ":camera_flash: High-performance CLI batch image resizer & rotator",
+ "homepage": "",
+ "owner": "jarun",
+ "repo": "imgp",
+ "rev": "9a50724cbc97a282ed79476398ab6ff3f6f7339e",
+ "sha256": "13r4fn3dd0nyidfhrr7zzpls5ifbyqdwxhyvpkqr8ahchws7wfc6",
+ "type": "tarball",
+ "url": "https://github.com/jarun/imgp/archive/9a50724cbc97a282ed79476398ab6ff3f6f7339e.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"lsd2dsl": {
"branch": "master",
"description": "Lingvo dictionaries decompiler",
diff --git a/pkgs/imgp/default.nix b/pkgs/imgp/default.nix
@@ -0,0 +1,22 @@
+{ lib, buildPythonApplication, pillow, imgp }:
+
+buildPythonApplication rec {
+ pname = "imgp";
+ version = lib.substring 0 7 src.rev;
+ src = imgp;
+
+ propagatedBuildInputs = [ pillow ];
+
+ installFlags = [
+ "DESTDIR=$(out)"
+ "PREFIX="
+ ];
+
+ meta = with lib; {
+ description = imgp.description;
+ homepage = "https://github.com/jarun/imgp";
+ license = licenses.gpl3;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ sikmir ];
+ };
+}