commit ee56c50dc5be1dc7fe93d8000756185fc6705ad8
parent 3d37cb6a0a160faf6fd52b0d8875b375d422d50e
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 20 Oct 2024 03:39:32 +0400
Add tinynetrc
Diffstat:
2 files changed, 31 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -120,6 +120,7 @@ lib.makeScope newScope (
pytest-skip-markers = callPackage ./development/python-modules/pytest-skip-markers { };
python-cmr = callPackage ./development/python-modules/python-cmr { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
+ tinynetrc = callPackage ./development/python-modules/tinynetrc { };
### EMBEDDED
diff --git a/pkgs/development/python-modules/tinynetrc/default.nix b/pkgs/development/python-modules/tinynetrc/default.nix
@@ -0,0 +1,30 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3Packages,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "tinynetrc";
+ version = "1.3.1";
+
+ src = fetchFromGitHub {
+ owner = "sloria";
+ repo = "tinynetrc";
+ rev = version;
+ hash = "sha256-iy0sa1oqJeZxSfXISI7Ypbml8+SGHhRZkznTdbI5yAo=";
+ };
+
+ nativeCheckInputs = with python3Packages; [
+ pytestCheckHook
+ ];
+
+ pythonImportsCheck = [ "tinynetrc" ];
+
+ meta = {
+ description = "Read and write .netrc files in Python";
+ homepage = "https://github.com/sloria/tinynetrc";
+ license = lib.licenses.mit;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}