commit 3d37cb6a0a160faf6fd52b0d8875b375d422d50e
parent 23dcabed8b375119c8c73f0df444e52345ced2fb
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 20 Oct 2024 03:30:54 +0400
Add python-cmr
Diffstat:
2 files changed, 40 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -118,6 +118,7 @@ lib.makeScope newScope (
pytest-mp = callPackage ./development/python-modules/pytest-mp { };
pytest-shell-utilities = callPackage ./development/python-modules/pytest-shell-utilities { };
pytest-skip-markers = callPackage ./development/python-modules/pytest-skip-markers { };
+ python-cmr = callPackage ./development/python-modules/python-cmr { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
### EMBEDDED
diff --git a/pkgs/development/python-modules/python-cmr/default.nix b/pkgs/development/python-modules/python-cmr/default.nix
@@ -0,0 +1,39 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3Packages,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "python-cmr";
+ version = "0.13.0";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "nasa";
+ repo = "python_cmr";
+ rev = "v${version}";
+ hash = "sha256-yQAWmX4PsaDx/x3AdQkVIOXAH72VvJ4Ow4QaoZq4/gc=";
+ };
+
+ build-system = with python3Packages; [ poetry-core ];
+
+ dependencies = with python3Packages; [
+ dateutil
+ requests
+ typing-extensions
+ ];
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook vcrpy ];
+
+ disabledTestPaths = [ "tests/test_multiple_queries.py" ];
+
+ pythonImportsCheck = [ "cmr" ];
+
+ meta = {
+ description = "Python wrapper to the NASA Common Metadata Repository (CMR) API";
+ homepage = "https://github.com/nasa/python_cmr";
+ license = lib.licenses.mit;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}