commit d6bc26cec9570136a07564aea10568040fc7dd55
parent a8defda25778caf2472cb22c1efd1c91c6fcd973
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 27 Jan 2024 20:59:35 +0400
Add shellprof
Diffstat:
2 files changed, 29 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -393,6 +393,7 @@ lib.makeScope newScope (
sdorfehs = callPackage ./misc/sdorfehs { };
serial-studio-bin = callPackage ./misc/serial-studio/bin.nix { };
serverpp = callPackage ./misc/serverpp { };
+ shellprof = callPackage ./misc/shellprof { };
socketcand = callPackage ./misc/socketcand { };
subprocess = callPackage ./misc/subprocess { };
tcvt = callPackage ./misc/tcvt { };
diff --git a/pkgs/misc/shellprof/default.nix b/pkgs/misc/shellprof/default.nix
@@ -0,0 +1,28 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "shellprof";
+ version = "2021-04-27";
+ format = "other";
+
+ src = fetchFromGitHub {
+ owner = "walles";
+ repo = "shellprof";
+ rev = "de6999bb37eb132cd18850acc28d988a994f4f86";
+ hash = "sha256-SlvQJF2AEvVv4Wt0mwBJ8K5RlHvT8fV5av3w3RuYQ5Q=";
+ };
+
+ dontUseSetuptoolsBuild = true;
+ dontUseSetuptoolsCheck = true;
+
+ installPhase = ''
+ install -Dm755 shellprof -t $out/bin
+ '';
+
+ meta = with lib; {
+ description = "Profile a shell script based on its printouts";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}