commit a8defda25778caf2472cb22c1efd1c91c6fcd973
parent f79b5dcb16c7d15c3bee0de4b6ea3bb3255aa57a
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 27 Jan 2024 20:52:28 +0400
Up
Diffstat:
6 files changed, 14 insertions(+), 13 deletions(-)
diff --git a/flake.nix b/flake.nix
@@ -12,7 +12,7 @@
} // flake-utils.lib.eachDefaultSystem (system:
let
config = {
- permittedInsecurePackages = [ "openssl-1.1.1w" ];
+ permittedInsecurePackages = [ "openssl-1.1.1w" "qtwebkit-5.212.0-alpha4" ];
};
pkgs = import nixpkgs {
inherit system config;
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -232,6 +232,7 @@ lib.makeScope newScope (
proj = pkgs.proj_7;
};
proj = pkgs.proj_7;
+ inherit garmindev;
};
render_geojson = callPackage ./geospatial/render_geojson {
wxGTK = pkgs.wxGTK32;
diff --git a/pkgs/linguistics/gdcv/default.nix b/pkgs/linguistics/gdcv/default.nix
@@ -2,13 +2,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "gdcv";
- version = "2020-05-14";
+ version = "2023-08-27";
src = fetchFromGitHub {
owner = "konstare";
repo = "gdcv";
- rev = "39fd2667362710f69c13dd596e112b0391e0a57e";
- hash = "sha256-JmT6n+VC6bbOOg+j+3bpUaoMn/Wr2Q4XDbQ6kxuLNe0=";
+ rev = "3151309d57d147231c63bd51fd0f01f10fd6ea55";
+ hash = "sha256-fzR+HKAZmvjiL4pBqfi3xIl5Ju0W3Hpy3SDHOmgoWZ0=";
};
postPatch = lib.optionalString stdenv.isDarwin ''
diff --git a/pkgs/linguistics/gt4gd/default.nix b/pkgs/linguistics/gt4gd/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonApplication rec {
pname = "gt4gd";
- version = "1.3.5";
+ version = "1.3.9";
src = fetchFromGitHub {
owner = "xinebf";
repo = "google-translate-for-goldendict";
rev = "v${version}";
- hash = "sha256-1WZo2pDYLUN4BgbYfTsrAZpWvNgixILkVL0NWlTCkRU=";
+ hash = "sha256-zJq5dhmrd0k7bsw75xFECKmwZU4qjw+wwSzsYjg8zao=";
};
propagatedBuildInputs = with python3Packages; [ requests ]
diff --git a/pkgs/linguistics/lsdreader/default.nix b/pkgs/linguistics/lsdreader/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonApplication rec {
pname = "lsdreader";
- version = "0.2.14";
+ version = "0.2.15";
src = fetchFromGitHub {
owner = "sv99";
repo = "lsdreader";
- rev = "c78ab22e794f1fbfbc93ffb3ee7ae481f54dd8c2";
- hash = "sha256-vTXfWTQ6TUZCyXo/PgJ/JaWf9mseKKQNz1+cA8KOKw0=";
+ rev = "v${version}";
+ hash = "sha256-8DYPFUmhgA4mxaliPjbPkywyJUwrl3J034scmFGE9no=";
};
doCheck = false;
@@ -16,7 +16,7 @@ python3Packages.buildPythonApplication rec {
meta = with lib; {
description = "Decompile Lingvo LSD dictionary to DSL";
inherit (src.meta) homepage;
- license = licenses.free;
+ license = licenses.mit;
maintainers = [ maintainers.sikmir ];
};
}
diff --git a/pkgs/linguistics/mikatools/default.nix b/pkgs/linguistics/mikatools/default.nix
@@ -2,16 +2,16 @@
python3Packages.buildPythonPackage rec {
pname = "mikatools";
- version = "1.0.0";
+ version = "1.0.1";
src = fetchFromGitHub {
owner = "mikahama";
repo = "mikatools";
rev = version;
- hash = "sha256-CfukGTPT0Yv4Q2H+g7XJfNgNchhslaA7/mgupqlOQ+o=";
+ hash = "sha256-2YpRTSZWJVXMoTLDBFS+tFkmA8pOBsqWF7Z85gtIfY0=";
};
- propagatedBuildInputs = with python3Packages; [ requests clint cryptography ];
+ propagatedBuildInputs = with python3Packages; [ requests cryptography tqdm ];
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];