commit c0b93d1d8df5fdab41f0c2542ba2fde27c512956
parent 8c3a200fefab94a278a01e16a831b9cf48e7e114
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 17 Jun 2022 11:50:34 +0300
Up
Diffstat:
3 files changed, 8 insertions(+), 7 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -173,7 +173,9 @@ lib.makeScope newScope (
geojson-pydantic = callPackage ./geospatial/geojson-pydantic { };
go-pmtiles = callPackage ./geospatial/go-pmtiles { };
go-staticmaps = callPackage ./geospatial/go-staticmaps { };
- hecate = callPackage ./geospatial/hecate { };
+ hecate = callPackage ./geospatial/hecate {
+ inherit (darwin.apple_sdk.frameworks) Security;
+ };
localtileserver = callPackage ./geospatial/localtileserver { };
mapsoft = callPackage ./geospatial/mapsoft {
proj = pkgs.proj_7;
diff --git a/pkgs/geospatial/hecate/default.nix b/pkgs/geospatial/hecate/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, rustPlatform, fetchFromGitHub, pkg-config, openssl }:
+{ lib, stdenv, rustPlatform, fetchFromGitHub, pkg-config, openssl, Security }:
rustPlatform.buildRustPackage rec {
pname = "hecate";
@@ -15,7 +15,7 @@ rustPlatform.buildRustPackage rec {
nativeBuildInputs = [ pkg-config ];
- buildInputs = [ openssl ];
+ buildInputs = [ openssl ] ++ lib.optional stdenv.isDarwin Security;
doCheck = false;
diff --git a/pkgs/geospatial/mapsoft/2.nix b/pkgs/geospatial/mapsoft/2.nix
@@ -24,14 +24,13 @@
stdenv.mkDerivation rec {
pname = "mapsoft2";
- version = "1.6";
+ version = "1.7";
src = fetchFromGitHub {
owner = "slazav";
repo = pname;
- #rev = "${version}-alt1";
- rev = "0986827ffe1d733c815e5002ba027904b65b4088";
- sha256 = "sha256-rR649zjVyMNS3TG4dtfi6QhHwdahsCvnd9TzEKYb+Bc=";
+ rev = "${version}-alt1";
+ sha256 = "sha256-wOxJdDl7y7iE6kKlfBNkknh68EJksjcKt6DFqkEdiIQ=";
fetchSubmodules = true;
};