commit 8c3a200fefab94a278a01e16a831b9cf48e7e114
parent 429e7be6a254d865ec36006ecce19c7934fc82bd
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 17 Jun 2022 11:12:15 +0300
Add hecate
Diffstat:
2 files changed, 29 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -173,6 +173,7 @@ lib.makeScope newScope (
geojson-pydantic = callPackage ./geospatial/geojson-pydantic { };
go-pmtiles = callPackage ./geospatial/go-pmtiles { };
go-staticmaps = callPackage ./geospatial/go-staticmaps { };
+ hecate = callPackage ./geospatial/hecate { };
localtileserver = callPackage ./geospatial/localtileserver { };
mapsoft = callPackage ./geospatial/mapsoft {
proj = pkgs.proj_7;
diff --git a/pkgs/geospatial/hecate/default.nix b/pkgs/geospatial/hecate/default.nix
@@ -0,0 +1,28 @@
+{ lib, stdenv, rustPlatform, fetchFromGitHub, pkg-config, openssl }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "hecate";
+ version = "0.82.2";
+
+ src = fetchFromGitHub {
+ owner = "Mapbox";
+ repo = "Hecate";
+ rev = "v${version}";
+ hash = "sha256-ffDBcrrg7iC8XkA1HO+qiRzZfNS6bF4mEXXqdM8w3uA=";
+ };
+
+ cargoHash = "sha256-OwKQiDRgYVSIIDnmjWyXSvFc3/L/dgcOjuXf/lE4N68=";
+
+ nativeBuildInputs = [ pkg-config ];
+
+ buildInputs = [ openssl ];
+
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Fast Geospatial Feature Storage API";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}