commit a8540c986ae71d70134e2b06097bb04928b5e772
parent 07e5cc57f2285a8c5e52021925d769d8707fa080
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 24 Jun 2020 12:52:52 +0300
Add hfst
Diffstat:
3 files changed, 30 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -270,6 +270,19 @@
"url": "https://github.com/OPHoperHPO/GT-bash-client/archive/28842d0fc5eb0aa86bc80dcdc9ef0df2ea43db38.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "hfst": {
+ "branch": "master",
+ "builtin": false,
+ "description": "Helsinki Finite-State Technology (library and application suite)",
+ "homepage": "https://hfst.github.io",
+ "owner": "hfst",
+ "repo": "hfst",
+ "rev": "265bc37a8fc61726f6665b31b82b0214d9b492e0",
+ "sha256": "0bdmnbwfc1zivw20n4s9ccjmzgfhi2v213dlc9d17fylwlx235fi",
+ "type": "tarball",
+ "url": "https://github.com/hfst/hfst/archive/265bc37a8fc61726f6665b31b82b0214d9b492e0.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"libshell": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -65,6 +65,7 @@ lib.makeScope newScope (
libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
};
geographiclib = callPackage ./development/libraries/geographiclib {};
+ hfst = callPackage ./development/libraries/hfst {};
libgarmin = callPackage ./development/libraries/libgarmin {
automake = pkgs.automake111x;
};
diff --git a/pkgs/development/libraries/hfst/default.nix b/pkgs/development/libraries/hfst/default.nix
@@ -0,0 +1,16 @@
+{ stdenv, autoreconfHook, bison, flex, sources }:
+
+stdenv.mkDerivation rec {
+ pname = "hfst";
+ version = stdenv.lib.substring 0 7 src.rev;
+ src = sources.hfst;
+
+ nativeBuildInputs = [ autoreconfHook bison flex ];
+
+ meta = with stdenv.lib; {
+ inherit (src) description homepage;
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}