commit 07e5cc57f2285a8c5e52021925d769d8707fa080
parent e34d43a2c34d0cbe69a1825e07079ad413d264f6
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 24 Jun 2020 12:51:06 +0300
Add mikatools
Diffstat:
3 files changed, 32 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -385,6 +385,19 @@
"url": "https://github.com/mapbox/mercantile/archive/9e7b52f6a2019f904b2ceba3f5f9ca6ac8f02b80.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "mikatools": {
+ "branch": "master",
+ "builtin": false,
+ "description": "Mikatools provides fast and easy methods for common Python coding tasks",
+ "homepage": "https://github.com/mikahama/mikatools",
+ "owner": "mikahama",
+ "repo": "mikatools",
+ "rev": "64a21f2af5c22f0f6ea8bb895286f260bcf61d00",
+ "sha256": "17wbddjz2jggqbb10c67lns2ni632ixd1rjfxbgiyja1fckzgx2x",
+ "type": "tarball",
+ "url": "https://github.com/mikahama/mikatools/archive/64a21f2af5c22f0f6ea8bb895286f260bcf61d00.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"morse-talk": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -90,6 +90,9 @@ lib.makeScope newScope (
mercantile = python3Packages.callPackage ./development/python-modules/mercantile {
inherit sources;
};
+ mikatools = python3Packages.callPackage ./development/python-modules/mikatools {
+ inherit sources;
+ };
pyephem = python3Packages.callPackage ./development/python-modules/pyephem {
inherit sources;
};
diff --git a/pkgs/development/python-modules/mikatools/default.nix b/pkgs/development/python-modules/mikatools/default.nix
@@ -0,0 +1,16 @@
+{ lib, buildPythonPackage, requests, clint, sources }:
+
+buildPythonPackage rec {
+ pname = "mikatools";
+ version = lib.substring 0 7 src.rev;
+ src = sources.mikatools;
+
+ propagatedBuildInputs = [ requests clint ];
+
+ meta = with lib; {
+ inherit (src) description homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}