commit a70308ed557f997b7ac59b8a8081d636541eb0c2
parent e40c31c3875a908ca901f5a2af2a3eaa47488ee3
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 19 Mar 2025 21:44:35 +0400
Add riverrem
Diffstat:
2 files changed, 39 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -240,6 +240,7 @@ lib.makeScope newScope (
rio-mbtiles = callPackage ./geospatial/rio-mbtiles { };
rio-mucho = callPackage ./geospatial/rio-mucho { };
rio-stac = callPackage ./geospatial/rio-stac { };
+ riverrem = callPackage ./geospatial/riverrem { };
rsgislib = callPackage ./geospatial/rsgislib { };
sasplanet = callPackage ./geospatial/sasplanet { };
server-thread = callPackage ./geospatial/server-thread { };
diff --git a/pkgs/geospatial/riverrem/default.nix b/pkgs/geospatial/riverrem/default.nix
@@ -0,0 +1,38 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3Packages,
+ cmocean,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "riverrem";
+ version = "1.1.0";
+
+ src = fetchFromGitHub {
+ owner = "OpenTopography";
+ repo = "RiverREM";
+ tag = "v${version}";
+ hash = "sha256-pMZahd4CfeGuLz5sd8rT9R0fi2N6hNHe5gBXi1UqYWg=";
+ };
+
+ dependencies = with python3Packages; [
+ cmocean
+ gdal
+ geopandas
+ numpy
+ osmnx
+ requests
+ scipy
+ seaborn
+ shapely
+ ];
+
+ meta = {
+ description = "Make river relative elevation models (REM) and REM visualizations from an input digital elevation model (DEM)";
+ homepage = "https://github.com/OpenTopography/RiverREM";
+ license = lib.licenses.gpl3;
+ maintainers = [ lib.maintainers.sikmir ];
+ inherit (cmocean.meta) broken;
+ };
+}