commit e40c31c3875a908ca901f5a2af2a3eaa47488ee3
parent 0d00a6e5801d7c9764426d5a1163c3a0e50b2d02
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 19 Mar 2025 21:30:30 +0400
Add cmocean
Diffstat:
2 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -198,6 +198,7 @@ lib.makeScope newScope (
arcgis2geojson = callPackage ./geospatial/arcgis2geojson { };
bbox = callPackage ./geospatial/bbox { };
c2cwsgiutils = callPackage ./geospatial/c2cwsgiutils { };
+ cmocean = callPackage ./geospatial/cmocean { };
cogdumper = callPackage ./geospatial/cogdumper { };
cogeo-mosaic = callPackage ./geospatial/cogeo-mosaic { };
datamaps = callPackage ./geospatial/datamaps { };
diff --git a/pkgs/geospatial/cmocean/default.nix b/pkgs/geospatial/cmocean/default.nix
@@ -0,0 +1,33 @@
+{
+ lib,
+ stdenv,
+ fetchFromGitHub,
+ python3Packages,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "cmocean";
+ version = "4.0.3";
+
+ src = fetchFromGitHub {
+ owner = "matplotlib";
+ repo = "cmocean";
+ tag = "v${version}";
+ hash = "sha256-Vi+tK2cAwqkoe2CEFCYEqMp28IgeH1MSJ+u3t6D8Zu8=";
+ };
+
+ dependencies = with python3Packages; [
+ matplotlib
+ numpy
+ ];
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = {
+ description = "Colormap setup for standardizing commonly-plotting oceanographic variables";
+ homepage = "https://github.com/matplotlib/cmocean";
+ license = lib.licenses.mit;
+ maintainers = [ lib.maintainers.sikmir ];
+ broken = stdenv.isDarwin;
+ };
+}