commit a405f2829fb898ad9eb38f840dd7d046db53b82f
parent f992142ea5c81f39e05cc366d8448962bb532119
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 29 Dec 2019 04:06:57 +0300
Fix names
Diffstat:
4 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/default.nix b/default.nix
@@ -44,10 +44,10 @@ in rec {
inherit (sources) gpxpy;
};
gpxsee = libsForQt5.callPackage ./pkgs/gpxsee {
- inherit (sources) GPXSee;
+ inherit (sources) gpxsee;
};
gpxsee-maps = callPackage ./pkgs/gpxsee-maps {
- inherit (sources) GPXSee-maps;
+ inherit (sources) gpxsee-maps;
};
gpxtools = callPackage ./pkgs/gpxtools {
inherit (sources) gpxtools;
diff --git a/nix/sources.json b/nix/sources.json
@@ -11,7 +11,7 @@
"url": "https://github.com/BourgeoisLab/GPXLab/archive/68721865f5fd6a5b2414da47a00778d5c342a461.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "GPXSee": {
+ "gpxsee": {
"branch": "master",
"description": "GPS log file viewer and analyzer with support for GPX, TCX, KML, FIT, IGC, NMEA, SLF, LOC, GeoJSON and OziExplorer files.",
"homepage": "https://www.gpxsee.org",
@@ -23,7 +23,7 @@
"url": "https://github.com/tumic0/GPXSee/archive/6839119794c5002c06b46bf0d1edf4420a388aac.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "GPXSee-maps": {
+ "gpxsee-maps": {
"branch": "master",
"description": "GPXSee maps",
"homepage": "http://www.gpxsee.org",
diff --git a/pkgs/gpxsee-maps/default.nix b/pkgs/gpxsee-maps/default.nix
@@ -1,9 +1,9 @@
-{ stdenv, GPXSee-maps }:
+{ stdenv, gpxsee-maps }:
stdenv.mkDerivation rec {
pname = "gpxsee-maps";
version = stdenv.lib.substring 0 7 src.rev;
- src = GPXSee-maps;
+ src = gpxsee-maps;
installPhase = ''
install -dm755 "$out/share/gpxsee/maps"
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
'';
meta = with stdenv.lib; {
- description = GPXSee-maps.description;
+ description = gpxsee-maps.description;
homepage = "https://github.com/tumic0/GPXSee-maps";
license = licenses.unlicense;
maintainers = with maintainers; [ sikmir ];
diff --git a/pkgs/gpxsee/default.nix b/pkgs/gpxsee/default.nix
@@ -1,9 +1,9 @@
-{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, GPXSee }:
+{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, gpxsee }:
mkDerivation rec {
pname = "gpxsee";
version = lib.substring 0 7 src.rev;
- src = GPXSee;
+ src = gpxsee;
nativeBuildInputs = [ qmake qttools ];
buildInputs = [ qtbase qttranslations ];
@@ -16,7 +16,7 @@ mkDerivation rec {
meta = with lib; {
homepage = "https://www.gpxsee.org/";
- description = GPXSee.description;
+ description = gpxsee.description;
license = licenses.gpl3;
maintainers = with maintainers; [ sikmir ];
platforms = platforms.linux;