commit 9a1dbb93e2853affec58aa739d23b9012fc1fd86
parent 7d48da8b5732ee90c40fa38c4c5b1d385cf2ff49
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 13 Oct 2020 01:31:57 +0300
Add goldencheetah-bin
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/goldencheetah/bin.nix b/pkgs/applications/goldencheetah/bin.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchfromgh, undmg }:
+let
+ pname = "goldencheetah";
+ version = "3.5";
+in
+stdenv.mkDerivation {
+ inherit pname version;
+
+ src = fetchfromgh {
+ owner = "GoldenCheetah";
+ repo = "GoldenCheetah";
+ version = "V${version}";
+ name = "GoldenCheetah_v${version}_64bit_MacOS.dmg";
+ sha256 = "0alg0a071lpkx0v3qqkqbb93vh1nsb3d7czxl9m15v17akp8nl82";
+ };
+
+ preferLocalBuild = true;
+
+ nativeBuildInputs = [ undmg ];
+
+ installPhase = ''
+ mkdir -p $out/Applications/GoldenCheetah.app
+ cp -R . $out/Applications/GoldenCheetah.app
+ '';
+
+ meta = with stdenv.lib; {
+ description = "Performance software for cyclists, runners and triathletes";
+ homepage = "https://www.goldencheetah.org/";
+ license = licenses.gpl3;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -10,6 +10,7 @@ lib.makeScope newScope (
anki-bin = callPackage ./applications/anki/bin.nix { };
basecamp = callPackage ./applications/basecamp { };
+ goldencheetah-bin = callPackage ./applications/goldencheetah/bin.nix { };
goldendict-bin = callPackage ./applications/goldendict/bin.nix { };
gpxlab = libsForQt5.callPackage ./applications/gpxlab {
inherit sources;