commit 7d48da8b5732ee90c40fa38c4c5b1d385cf2ff49
parent 5f729e9598d849a2eeae595d135b003c4991e474
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 12 Oct 2020 12:25:32 +0300
librewolf: use undmg
Diffstat:
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/pkgs/applications/librewolf/default.nix b/pkgs/applications/librewolf/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, fetchurl, appimageTools, lang ? "en-US" }:
+{ stdenv, fetchgit, fetchurl, appimageTools, undmg, lang ? "en-US" }:
let
inherit (stdenv.hostPlatform) system;
throwSystem = throw "Unsupported system: ${system}";
@@ -78,10 +78,9 @@ let
'';
installPhase = ''
- /usr/bin/hdiutil mount -nobrowse -mountpoint librewolf-mnt LibreWolf.dmg
+ ${undmg}/bin/undmg LibreWolf.dmg
mkdir -p $out/Applications
- cp -r ./librewolf-mnt/LibreWolf.app $out/Applications
- /usr/bin/hdiutil unmount librewolf-mnt
+ cp -R LibreWolf.app $out/Applications
'';
};
in