commit 98f5bb473849b1e4b1e54991f66cc47f7b4c04d9
parent e28bab0a5690a5cea6f6569407b363c88f44808a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 8 Feb 2020 12:12:14 +0300
Add cheetah3
Diffstat:
3 files changed, 32 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -21,6 +21,9 @@ in rec {
inherit ueberzug;
inherit (sources) cfiles;
};
+ cheetah3 = python3Packages.callPackage ./pkgs/development/python-modules/cheetah3 {
+ inherit (sources) cheetah3;
+ };
click = python3Packages.callPackage ./pkgs/development/python-modules/click { };
csvquote = callPackage ./pkgs/tools/text/csvquote {
inherit (sources) csvquote;
diff --git a/nix/sources.json b/nix/sources.json
@@ -11,6 +11,18 @@
"url": "https://github.com/mananapr/cfiles/archive/ee3f001225764cf38161bafd463c30cf64249de4.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "cheetah3": {
+ "branch": "master",
+ "description": "Cheetah3 is a free (MIT) and open source template engine for Python.",
+ "homepage": "https://cheetahtemplate.org/",
+ "owner": "CheetahTemplate3",
+ "repo": "cheetah3",
+ "rev": "44ebf7f59a749322fcc397b21611ad487193e697",
+ "sha256": "1962imkj6w54h5c46jnxx79lpc7dw5a731p38j8z4630hwzli1dw",
+ "type": "tarball",
+ "url": "https://github.com/CheetahTemplate3/cheetah3/archive/44ebf7f59a749322fcc397b21611ad487193e697.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"csvquote": {
"branch": "master",
"description": "Enables common unix utlities like cut, awk, wc, head to work correctly with csv data containing delimiters and newlines",
diff --git a/pkgs/development/python-modules/cheetah3/default.nix b/pkgs/development/python-modules/cheetah3/default.nix
@@ -0,0 +1,17 @@
+{ lib, buildPythonPackage, cheetah3 }:
+
+buildPythonPackage rec {
+ pname = "cheetah3";
+ version = lib.substring 0 7 src.rev;
+ src = cheetah3;
+
+ doCheck = false;
+
+ meta = with lib; {
+ description = cheetah3.description;
+ homepage = cheetah3.homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}