commit e28bab0a5690a5cea6f6569407b363c88f44808a
parent 327f715b3c6f7c8706f6fae1e7ad77e6c61c01e7
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 8 Feb 2020 12:04:50 +0300
Add pyephem
Diffstat:
3 files changed, 30 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -97,6 +97,9 @@ in rec {
inherit (sources) mapper;
};
ptunnel = callPackage ./pkgs/tools/networking/ptunnel { };
+ pyephem = python3Packages.callPackage ./pkgs/development/python-modules/pyephem {
+ inherit (sources) pyephem;
+ };
pymbtiles = python3Packages.callPackage ./pkgs/development/python-modules/pymbtiles {
inherit (sources) pymbtiles;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -275,6 +275,18 @@
"url": "https://github.com/btittelbach/openmtbmap_openvelomap_linux/archive/6d00e273d7391fae72fb7fd21859483db3e26c1a.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "pyephem": {
+ "branch": "master",
+ "description": "Scientific-grade astronomy routines for Python",
+ "homepage": "https://rhodesmill.org/pyephem",
+ "owner": "brandon-rhodes",
+ "repo": "pyephem",
+ "rev": "db3e617e73d814efd994a259a5df9addac721774",
+ "sha256": "100lic8qkj1xnbc64zv378azjap57zvlkqw2kxdncp1xdcbiz7hq",
+ "type": "tarball",
+ "url": "https://github.com/brandon-rhodes/pyephem/archive/db3e617e73d814efd994a259a5df9addac721774.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"pymbtiles": {
"branch": "master",
"description": "Python utilities for Mapbox mbtiles files",
diff --git a/pkgs/development/python-modules/pyephem/default.nix b/pkgs/development/python-modules/pyephem/default.nix
@@ -0,0 +1,15 @@
+{ lib, buildPythonPackage, pyephem }:
+
+buildPythonPackage rec {
+ pname = "pyephem";
+ version = lib.substring 0 7 src.rev;
+ src = pyephem;
+
+ meta = with lib; {
+ description = pyephem.description;
+ homepage = pyephem.homepage;
+ license = licenses.lgpl3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}