commit 9204a7cdd1804c4c27b430fa3b63bde6ea72be5e
parent 770b3ea8f9ec919d6fcee4e6ff84aa03370dce9b
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 30 Sep 2021 20:08:03 +0300
Add arcgis2geojson
Diffstat:
2 files changed, 24 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -180,6 +180,7 @@ lib.makeScope newScope (
### GEOSPATIAL
+ arcgis2geojson = callPackage ./geospatial/arcgis2geojson { };
datamaps = callPackage ./geospatial/datamaps { };
elevation = callPackage ./geospatial/elevation {
click = click-6-7;
diff --git a/pkgs/geospatial/arcgis2geojson/default.nix b/pkgs/geospatial/arcgis2geojson/default.nix
@@ -0,0 +1,23 @@
+{ lib, python3Packages, fetchFromGitHub, poetry }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "arcgis2geojson";
+ version = "2.0.1";
+ format = "pyproject";
+
+ src = fetchFromGitHub {
+ owner = "chris48s";
+ repo = pname;
+ rev = version;
+ hash = "sha256-NA1yNNZbx7ATFhgo2Be38liHQ5DWr66FDd24FaYur3M=";
+ };
+
+ nativeBuildInputs = [ poetry ];
+
+ meta = with lib; {
+ description = "A Python library for converting ArcGIS JSON to GeoJSON";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}