commit 770b3ea8f9ec919d6fcee4e6ff84aa03370dce9b
parent a83ee8d0dc734bb990349b501abb9855334319f9
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 29 Sep 2021 23:47:24 +0300
Up
Diffstat:
4 files changed, 26 insertions(+), 13 deletions(-)
diff --git a/pkgs/data/maps/maptourist/default.nix b/pkgs/data/maps/maptourist/default.nix
@@ -2,11 +2,11 @@
stdenvNoCC.mkDerivation rec {
pname = "maptourist";
- version = "2021-09-26";
+ version = "2021-09-28";
src = fetchurl {
url = "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-szfo-RU_${version}.zip";
- hash = "sha256-NpP65DZmOJUP/dcV3QyFP+nFgwQyK+6iaCByC0YSeSo=";
+ hash = "sha256-Sa3zgCpol93t76XSNWp0FmIn5Ah6Bc7Grx282TS0ors=";
};
sourceRoot = ".";
diff --git a/pkgs/development/python-modules/wikitextprocessor/default.nix b/pkgs/development/python-modules/wikitextprocessor/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonApplication rec {
pname = "wikitextprocessor";
- version = "2021-09-10";
+ version = "0.4.95";
src = fetchFromGitHub {
owner = "tatuylonen";
repo = pname;
- rev = "29ae764a226a941664e12bef0ae1f376c6d84f48";
- hash = "sha256-BkHPds0fSzbSKnPDOo5IuXixsOmNMD2YKx8EetglcB0=";
+ rev = "v${version}";
+ hash = "sha256-YLlgjMGIifymdQfsZKnf3aRsMIyA35X/sQSqNj5t1TM=";
};
propagatedBuildInputs = with python3Packages; [ lupa dateparser lru-dict ];
diff --git a/pkgs/dict/wiktextract/default.nix b/pkgs/dict/wiktextract/default.nix
@@ -1,19 +1,32 @@
-{ lib, python3Packages, fetchFromGitHub, wikitextprocessor }:
+{ lib, python3Packages, fetchFromGitHub, fetchurl, unzip, wikitextprocessor }:
+let
+ brown = fetchurl {
+ url = "https://raw.githubusercontent.com/nltk/nltk_data/gh-pages/packages/corpora/brown.zip";
+ hash = "sha256-mydfmzuV171mzPt80ln0RaE7vl0fQQeroJ/T6DZLr6Y=";
+ };
+in
python3Packages.buildPythonApplication rec {
pname = "wiktextract";
- version = "1.99.5";
+ version = "1.99.6";
src = fetchFromGitHub {
owner = "tatuylonen";
repo = pname;
rev = "v${version}";
- hash = "sha256-am926XGY2XlJXVqVQyfWvFhiOkanuSXpq07ckPChnpU=";
+ hash = "sha256-EWdZt3jTSJyd4GSzGF4J2HRHUNw9J58lGlKaay40lXg=";
};
- propagatedBuildInputs = with python3Packages; [ python-Levenshtein setuptools wikitextprocessor ];
+ propagatedBuildInputs = with python3Packages; [ python-Levenshtein setuptools wikitextprocessor nltk ];
+
+ checkInputs = with python3Packages; [ pytestCheckHook unzip ];
- checkInputs = with python3Packages; [ pytestCheckHook ];
+ # https://www.nltk.org/data.html#manual-installation
+ preCheck = ''
+ export NLTK_DATA=$PWD/nltk_data
+ mkdir -p nltk_data/corpora
+ unzip ${brown} -d nltk_data/corpora
+ '';
meta = with lib; {
description = "Wiktionary dump file parser and multilingual data extractor";
diff --git a/pkgs/osm/map-machine/default.nix b/pkgs/osm/map-machine/default.nix
@@ -2,14 +2,14 @@
python3Packages.buildPythonApplication rec {
pname = "map-machine";
- version = "2021-09-26";
+ version = "2021-09-28";
disabled = python3Packages.pythonOlder "3.9";
src = fetchFromGitHub {
owner = "enzet";
repo = pname;
- rev = "4644d381665bdc1f2ea12bd6d9a70134c6ed9928";
- hash = "sha256-DZnbFBZpJWPjilA0wSDS/q7aqHG0Hd9EUWBNMaSZLtI=";
+ rev = "eacb6c8ee1bb2f1f22591593e54711733c8f943a";
+ hash = "sha256-FFqphxNVIfR6RBiXa7/uMKWrVuZQcc9MrzQy4RWE814=";
};
propagatedBuildInputs = with python3Packages; [