commit 89e0c221d0370ff9bc362411b0a6538b4948c946
parent 2ab2ab4724d4dd504f806df284d6f99a5d8f3011
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 19 Dec 2019 11:10:00 +0300
Add gt4gd
Diffstat:
3 files changed, 39 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -10,5 +10,6 @@ in
gpx-layer = perlPackages.callPackage ./pkgs/gpx-layer { inherit (sources) gpx-layer; };
gpxpy = python3Packages.callPackage ./pkgs/gpxpy { inherit (sources) gpxpy; };
gpxsee-maps = callPackage ./pkgs/gpxsee-maps { inherit (sources) GPXSee-maps; };
+ gt4gd = python3Packages.callPackage ./pkgs/gt4gd { inherit (sources) google-translate-for-goldendict; };
mbutil = python3Packages.callPackage ./pkgs/mbutil { inherit (sources) mbutil; };
}
diff --git a/nix/sources.json b/nix/sources.json
@@ -23,6 +23,18 @@
"url": "https://github.com/ericfischer/datamaps/archive/76e620adabbedabd6866b23b30c145b53bae751e.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "google-translate-for-goldendict": {
+ "branch": "master",
+ "description": "Add Google translate to GoldenDict",
+ "homepage": "",
+ "owner": "xinebf",
+ "repo": "google-translate-for-goldendict",
+ "rev": "d8a271ed5f8b9db6c7504f5ebcc0a0bd0380b0c8",
+ "sha256": "1wmxyak6b86657wavfxi33m3l60v10r8n26fjv6z47krk7a318a1",
+ "type": "tarball",
+ "url": "https://github.com/xinebf/google-translate-for-goldendict/archive/d8a271ed5f8b9db6c7504f5ebcc0a0bd0380b0c8.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"gpx-layer": {
"branch": "master",
"description": "Tools to turn GPX files into a GPS map tracing layer",
diff --git a/pkgs/gt4gd/default.nix b/pkgs/gt4gd/default.nix
@@ -0,0 +1,26 @@
+{ lib, buildPythonApplication, requests, google-translate-for-goldendict }:
+
+buildPythonApplication rec {
+ pname = "gt4gd";
+ version = lib.substring 0 7 src.rev;
+ src = google-translate-for-goldendict;
+
+ propagatedBuildInputs = [ requests ];
+
+ preConfigure = ''
+ touch setup.py
+ '';
+
+ installPhase = ''
+ install -Dm755 googletranslate.py $out/bin/gt4gd
+ install -Dm644 google_translate.png $out/share/gt4gd/gt.png
+ '';
+
+ meta = with lib; {
+ description = google-translate-for-goldendict.description;
+ homepage = "https://github.com/xinebf/google-translate-for-goldendict";
+ license = licenses.gpl3;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ sikmir ];
+ };
+}