commit 2ab2ab4724d4dd504f806df284d6f99a5d8f3011
parent 7951f34e6761d9303a5da3ab7acf74e39a87cef3
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 19 Dec 2019 09:46:51 +0300
Add gpxsee-maps
Diffstat:
3 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -9,5 +9,6 @@ in
datamaps = callPackage ./pkgs/datamaps { inherit (sources) datamaps; };
gpx-layer = perlPackages.callPackage ./pkgs/gpx-layer { inherit (sources) gpx-layer; };
gpxpy = python3Packages.callPackage ./pkgs/gpxpy { inherit (sources) gpxpy; };
+ gpxsee-maps = callPackage ./pkgs/gpxsee-maps { inherit (sources) GPXSee-maps; };
mbutil = python3Packages.callPackage ./pkgs/mbutil { inherit (sources) mbutil; };
}
diff --git a/nix/sources.json b/nix/sources.json
@@ -1,4 +1,16 @@
{
+ "GPXSee-maps": {
+ "branch": "master",
+ "description": "GPXSee maps",
+ "homepage": "http://www.gpxsee.org",
+ "owner": "tumic0",
+ "repo": "GPXSee-maps",
+ "rev": "8d53800eb0ce4d9240a145959bccb94513128a17",
+ "sha256": "18rqar7qzdjypw8b0cyixkjvvmcksl7n949kxj0bcl8fq5y7lfsf",
+ "type": "tarball",
+ "url": "https://github.com/tumic0/GPXSee-maps/archive/8d53800eb0ce4d9240a145959bccb94513128a17.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"datamaps": {
"branch": "master",
"description": "Indexes points and lines and generates map tiles to display them",
diff --git a/pkgs/gpxsee-maps/default.nix b/pkgs/gpxsee-maps/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, GPXSee-maps }:
+
+stdenv.mkDerivation rec {
+ pname = "gpxsee-maps";
+ version = stdenv.lib.substring 0 7 src.rev;
+ src = GPXSee-maps;
+
+ installPhase = ''
+ install -dm755 "$out/share/gpxsee/maps"
+ cp -r World "$out/share/gpxsee/maps"
+ '';
+
+ meta = with stdenv.lib; {
+ description = GPXSee-maps.description;
+ homepage = https://github.com/tumic0/GPXSee-maps;
+ license = licenses.unlicense;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}