commit 84922e54da8a9138ed7bcefb2306c8d96e3f6fe9
parent 6776d4f53493363b5932062c9d65ce3046d6542d
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 9 Jul 2020 18:11:40 +0300
Update .travis.yml
Diffstat:
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/.travis.yml b/.travis.yml
@@ -1,14 +1,12 @@
language: nix
nix: 2.3.6
-sudo: yes
-
env:
global:
- CACHIX_CACHE=sikmir
- NUR_REPO=sikmir
-matrix:
+jobs:
include:
- env: NIX_CHANNEL=https://nixos.org/channels/nixpkgs-unstable
os: linux
@@ -35,8 +33,6 @@ before_install:
- echo "trusted-users = root $USER" | sudo tee -a /etc/nix/nix.conf
- echo 'require-sigs = false' | sudo tee -a /etc/nix/nix.conf > /dev/null
- echo "substituters = https://cache.nixos.org/ https://${CACHIX_CACHE}.cachix.org https://cachix.cachix.org file://$HOME/nix.store" | sudo tee -a /etc/nix/nix.conf > /dev/null
- - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then sudo launchctl stop ors.nixos.nix-daemon; fi
- - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then sudo launchctl start ors.nixos.nix-daemon && sleep 5; fi
install:
- nix --version