commit 6776d4f53493363b5932062c9d65ce3046d6542d
parent 52a2a17663141579f18559bc43f556c227e5e6ab
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 9 Jul 2020 17:25:33 +0300
Update .travis.yml
Diffstat:
1 file changed, 10 insertions(+), 0 deletions(-)
diff --git a/.travis.yml b/.travis.yml
@@ -11,8 +11,16 @@ env:
matrix:
include:
- env: NIX_CHANNEL=https://nixos.org/channels/nixpkgs-unstable
+ os: linux
- env: NIX_CHANNEL=https://nixos.org/channels/nixos-unstable
+ os: linux
- env: NIX_CHANNEL=https://nixos.org/channels/nixos-20.03
+ os: linux
+ - env: NIX_CHANNEL=https://nixos.org/channels/nixpkgs-unstable
+ os: osx
+ allow_failures:
+ - env: NIX_CHANNEL=https://nixos.org/channels/nixpkgs-unstable
+ os: osx
cache:
directories:
@@ -27,6 +35,8 @@ before_install:
- echo "trusted-users = root $USER" | sudo tee -a /etc/nix/nix.conf
- echo 'require-sigs = false' | sudo tee -a /etc/nix/nix.conf > /dev/null
- echo "substituters = https://cache.nixos.org/ https://${CACHIX_CACHE}.cachix.org https://cachix.cachix.org file://$HOME/nix.store" | sudo tee -a /etc/nix/nix.conf > /dev/null
+ - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then sudo launchctl stop ors.nixos.nix-daemon; fi
+ - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then sudo launchctl start ors.nixos.nix-daemon && sleep 5; fi
install:
- nix --version