commit 7be7fb31f498458dc44c6d95357df61e0dc38a5c
parent b1ed0f6df6aac56093c09c1e955dbc93ea39b3f5
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 5 Mar 2023 23:07:06 +0400
Up
Diffstat:
2 files changed, 12 insertions(+), 4 deletions(-)
diff --git a/pkgs/darwin/pinentry-touchid/default.nix b/pkgs/darwin/pinentry-touchid/default.nix
@@ -25,5 +25,6 @@ buildGoModule rec {
license = licenses.asl20;
maintainers = [ maintainers.sikmir ];
platforms = platforms.darwin;
+ skip.ci = !stdenv.isDarwin;
};
}
diff --git a/pkgs/mqtt/influxdb-cxx/default.nix b/pkgs/mqtt/influxdb-cxx/default.nix
@@ -1,19 +1,26 @@
-{ lib, stdenv, fetchFromGitHub, cmake, curl, boost, catch2, trompeloeil }:
+{ lib, stdenv, fetchFromGitHub, cmake, cpr, boost, catch2, trompeloeil }:
stdenv.mkDerivation (finalAttrs: {
pname = "influxdb-cxx";
- version = "0.6.7";
+ version = "0.7.0";
src = fetchFromGitHub {
owner = "offa";
repo = "influxdb-cxx";
rev = "v${finalAttrs.version}";
- hash = "sha256-9CfjW+NEVGCfV+A0PDy9N6attE2eNdgKBXTzZ3g51FM=";
+ hash = "sha256-ALv6RnWcvonNfoFJfbjVyUdPZ3FWBavGXhvppr5UdWM=";
};
nativeBuildInputs = [ cmake ];
- buildInputs = [ curl boost catch2 trompeloeil ];
+ buildInputs = [ cpr boost ]
+ ++ lib.optionals finalAttrs.doCheck [ catch2 trompeloeil ];
+
+ cmakeFlags = [
+ "-DINFLUXCXX_TESTING=${if finalAttrs.doCheck then "ON" else "OFF"}"
+ ];
+
+ doCheck = false;
meta = with lib; {
description = "InfluxDB C++ client library";