commit 7ad7bc4477c3deed8fcc642541eef0f68f5fe3e4
parent 6bab3f28e71e4ca8d906576d714ad2428b1bb219
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 10 Dec 2023 19:20:25 +0400
Up
Diffstat:
2 files changed, 11 insertions(+), 10 deletions(-)
diff --git a/pkgs/linguistics/tatoebatools/cli.patch b/pkgs/linguistics/tatoebatools/cli.patch
@@ -1,23 +1,24 @@
diff --git c/setup.py i/setup.py
-index 10ad3c2..4cf6338 100644
+index 387f33e..b8d2cd0 100644
--- c/setup.py
+++ i/setup.py
-@@ -25,9 +25,12 @@ setuptools.setup(
+@@ -26,10 +26,13 @@ setuptools.setup(
python_requires=">=3.8.0",
install_requires=[
- "beautifulsoup4>=4.9.0",
+ "beautifulsoup4>=4.12.2",
+ "click",
- "pandas>=1.5.0",
- "requests>=2.23.0",
- "SQLAlchemy==1.4.23",
- "tqdm>=4.46.0",
+ "importlib-resources>=6.1.1;python_version<'3.9'",
+ "pandas>=2.0.3",
+ "requests>=2.31.0",
+ "SQLAlchemy>=2.0.23",
+ "tqdm>=4.66.1",
+ "xdg-base-dirs",
],
+ entry_points={"console_scripts": "parallel_corpus=tatoebatools.cli:parallel_corpus"},
)
diff --git c/tatoebatools/cli.py i/tatoebatools/cli.py
new file mode 100644
-index 0000000..f128aec
+index 0000000..76a4ef0
--- /dev/null
+++ i/tatoebatools/cli.py
@@ -0,0 +1,13 @@
diff --git a/pkgs/linguistics/tatoebatools/default.nix b/pkgs/linguistics/tatoebatools/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonApplication rec {
pname = "tatoebatools";
- version = "0.2.2";
+ version = "0.2.3";
src = fetchFromGitHub {
owner = "LBeaudoux";
repo = "tatoebatools";
rev = "v${version}";
- hash = "sha256-/xg57VYlrdfJV/6uvWsb+6OE5Hl4Vb9pukC5IvYRhoA=";
+ hash = "sha256-45CDAH80z6zApgR4gK7ZLPSXtCyPx+6YaA61Iskued4=";
};
patches = lib.optional (!checkLang) ./dont-check-lang-validity.patch