commit 6daee44a6c0d522dce1589eab7b3629c1b805b9a
parent 4f47b685611fba4913070fc792f58bf42ca29ff1
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 24 Apr 2021 21:30:54 +0300
Up
Diffstat:
4 files changed, 34 insertions(+), 58 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -55,20 +55,6 @@
"url": "https://github.com/mhulden/foma/archive/b44022c7d9d347dc7392aabbf72c82e558767675.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "gdcv": {
- "branch": "master",
- "builtin": false,
- "date": "2020-05-14T16:41:01Z",
- "description": "GoldenDict console version and emacs dynamic module",
- "homepage": "https://github.com/konstare/gdcv",
- "owner": "konstare",
- "repo": "gdcv",
- "rev": "39fd2667362710f69c13dd596e112b0391e0a57e",
- "sha256": "1v9micdr6fml1lbhxndbynghrajix5vgp8qg7b7bdsa2wngzlr16",
- "type": "tarball",
- "url": "https://github.com/konstare/gdcv/archive/39fd2667362710f69c13dd596e112b0391e0a57e.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"geofabrik-estonia": {
"builtin": false,
"sha256": "07gy3280arvkvfpm82aqcing1w7av6hq3crf5wxm66ipk2viwmg7",
@@ -107,20 +93,6 @@
"url": "https://github.com/wuyongzheng/gimgtools/archive/92d015749e105c5fb8eb704ae503a5c7e51af2bd.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "gpx-interpolate": {
- "branch": "master",
- "builtin": false,
- "date": "2021-01-24T21:39:05Z",
- "description": "Python script to interpolate GPX files using linear or spline interpolation",
- "homepage": "https://github.com/remisalmon/gpx_interpolate",
- "owner": "remisalmon",
- "repo": "gpx_interpolate",
- "rev": "24236e45e3d8baa0662c329b735b79a17e84c1bd",
- "sha256": "0gi8xq7gsmi1a6gbp4d0a0h6ys2jpf0b1fys3ggph5gqf47h9pvc",
- "type": "tarball",
- "url": "https://github.com/remisalmon/gpx_interpolate/archive/24236e45e3d8baa0662c329b735b79a17e84c1bd.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"gpxelevations": {
"branch": "master",
"builtin": false,
@@ -149,20 +121,6 @@
"url": "https://github.com/BourgeoisLab/GPXLab/archive/0a2e13756ed1c39f4278b0b3d6cef7f8ac9f6fe7.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "gpxlib": {
- "branch": "master",
- "builtin": false,
- "date": "2021-02-16T17:32:51Z",
- "description": "A c++ library for parsing, browsing, changing and writing of GPX files",
- "homepage": "http://irdvo.nl/gpxlib/",
- "owner": "irdvo",
- "repo": "gpxlib",
- "rev": "43df92be29412b7f3b58e63ebea516df9f15b883",
- "sha256": "0s8k3gl7w4i26jf4fqv98mlhrm16vzw2yn35rpqmzy87vpc9sbh2",
- "type": "tarball",
- "url": "https://github.com/irdvo/gpxlib/archive/43df92be29412b7f3b58e63ebea516df9f15b883.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"gpxsee-maps": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/development/libraries/gpxlib/default.nix b/pkgs/development/libraries/gpxlib/default.nix
@@ -1,10 +1,15 @@
-{ lib, stdenv, cmake, expat, sources }:
+{ lib, stdenv, fetchFromGitHub, cmake, expat }:
-stdenv.mkDerivation {
- pname = "gpxlib-unstable";
- version = lib.substring 0 10 sources.gpxlib.date;
+stdenv.mkDerivation rec {
+ pname = "gpxlib";
+ version = "2021-02-16";
- src = sources.gpxlib;
+ src = fetchFromGitHub {
+ owner = "irdvo";
+ repo = pname;
+ rev = "43df92be29412b7f3b58e63ebea516df9f15b883";
+ hash = "sha256-Ai6d2N0H+V/xzWVYL/jfJtQMaUVpY0ecNCISfugbE2k=";
+ };
nativeBuildInputs = [ cmake ];
@@ -23,7 +28,8 @@ stdenv.mkDerivation {
'';
meta = with lib; {
- inherit (sources.gpxlib) description homepage;
+ description = "A c++ library for parsing, browsing, changing and writing of GPX files";
+ homepage = "http://irdvo.nl/gpxlib/";
license = licenses.lgpl3Plus;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
diff --git a/pkgs/dict/gdcv/default.nix b/pkgs/dict/gdcv/default.nix
@@ -1,10 +1,15 @@
-{ lib, stdenv, pkg-config, emacs, zlib, sources }:
+{ lib, stdenv, fetchFromGitHub, pkg-config, emacs, zlib }:
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
pname = "gdcv";
- version = lib.substring 0 10 sources.gdcv.date;
+ version = "2020-05-14";
- src = sources.gdcv;
+ src = fetchFromGitHub {
+ owner = "konstare";
+ repo = pname;
+ rev = "39fd2667362710f69c13dd596e112b0391e0a57e";
+ hash = "sha256-JmT6n+VC6bbOOg+j+3bpUaoMn/Wr2Q4XDbQ6kxuLNe0=";
+ };
nativeBuildInputs = [ pkg-config ];
@@ -18,7 +23,8 @@ stdenv.mkDerivation {
'';
meta = with lib; {
- inherit (sources.gdcv) description homepage;
+ description = "GoldenDict console version and emacs dynamic module";
+ inherit (src.meta) homepage;
license = licenses.gpl3;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
diff --git a/pkgs/tools/geo/gpx-interpolate/default.nix b/pkgs/tools/geo/gpx-interpolate/default.nix
@@ -1,10 +1,15 @@
-{ lib, python3Packages, sources }:
+{ lib, fetchFromGitHub, python3Packages }:
-python3Packages.buildPythonApplication {
+python3Packages.buildPythonApplication rec {
pname = "gpx_interpolate";
- version = lib.substring 0 10 sources.gpx-interpolate.date;
+ version = "2021-01-24";
- src = sources.gpx-interpolate;
+ src = fetchFromGitHub {
+ owner = "remisalmon";
+ repo = pname;
+ rev = "24236e45e3d8baa0662c329b735b79a17e84c1bd";
+ hash = "sha256-bN8ED3H4FXjfG9q7sIC7UmhvIFCgkbueUSFW/Q7uKD4=";
+ };
propagatedBuildInputs = with python3Packages; [ gpxpy scipy numpy ];
@@ -19,7 +24,8 @@ python3Packages.buildPythonApplication {
'';
meta = with lib; {
- inherit (sources.gpx-interpolate) description homepage;
+ description = "Python script to interpolate GPX files using linear or spline interpolation";
+ inherit (src.meta) homepage;
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;