commit 4f47b685611fba4913070fc792f58bf42ca29ff1
parent 7ef42b680454bfd3c2a62875af34fb4a655c23e9
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 24 Apr 2021 19:42:59 +0300
Up
Diffstat:
3 files changed, 23 insertions(+), 39 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -13,20 +13,6 @@
"url": "https://github.com/ruarxive/apibackuper/archive/1ff139f688d59b899ff041ccc282e224110ddc76.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "dict2rest": {
- "branch": "master",
- "builtin": false,
- "date": "2016-12-05T08:16:58Z",
- "description": "A simple proxy service providing an HTTP interface to a Dict protocol (RFC 2229) server",
- "homepage": "https://github.com/felix/go-dict2rest",
- "owner": "felix",
- "repo": "go-dict2rest",
- "rev": "b049991a46a2f619344bd6e915745703864d0134",
- "sha256": "0d3fbqyyzy1rxpv76phkbfzrx9ianckq30a87k982rchs6qw36xz",
- "type": "tarball",
- "url": "https://github.com/felix/go-dict2rest/archive/b049991a46a2f619344bd6e915745703864d0134.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"docker-reg-tool": {
"branch": "master",
"builtin": false,
@@ -454,20 +440,6 @@
"url": "https://github.com/brandon-rhodes/pyephem/archive/6aac05e01f2bfc323779b21933721a4a059b1564.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "pymbtiles": {
- "branch": "main",
- "builtin": false,
- "date": "2021-02-16T00:08:01Z",
- "description": "Python utilities for Mapbox mbtiles files",
- "homepage": "https://github.com/consbio/pymbtiles",
- "owner": "consbio",
- "repo": "pymbtiles",
- "rev": "5094f77de6fb920092952df68aa64f91bf2aa097",
- "sha256": "0ds31ddphaipk4wf0ch6rm61y26vlw1qdbr9pvywc7p4qnhpf6k8",
- "type": "tarball",
- "url": "https://github.com/consbio/pymbtiles/archive/5094f77de6fb920092952df68aa64f91bf2aa097.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"qtpbfimageplugin-styles": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/development/python-modules/pymbtiles/default.nix b/pkgs/development/python-modules/pymbtiles/default.nix
@@ -1,15 +1,21 @@
-{ lib, python3Packages, sources }:
+{ lib, fetchFromGitHub, python3Packages }:
-python3Packages.buildPythonPackage {
- pname = "pymbtiles-unstable";
- version = lib.substring 0 10 sources.pymbtiles.date;
+python3Packages.buildPythonPackage rec {
+ pname = "pymbtiles";
+ version = "2021-02-16";
- src = sources.pymbtiles;
+ src = fetchFromGitHub {
+ owner = "consbio";
+ repo = pname;
+ rev = "5094f77de6fb920092952df68aa64f91bf2aa097";
+ hash = "sha256-aBp3ocXkHsb9vimvhgOn2wgfTM0GMuA4mTcqeFsLQzc=";
+ };
checkInputs = with python3Packages; [ pytestCheckHook ];
meta = with lib; {
- inherit (sources.pymbtiles) description homepage;
+ description = "Python utilities for Mapbox mbtiles files";
+ inherit (src.meta) homepage;
license = licenses.isc;
maintainers = [ maintainers.sikmir ];
};
diff --git a/pkgs/dict/dict2rest/default.nix b/pkgs/dict/dict2rest/default.nix
@@ -1,15 +1,21 @@
-{ lib, buildGoPackage, sources }:
+{ lib, fetchFromGitHub, buildGoPackage }:
-buildGoPackage {
+buildGoPackage rec {
pname = "dict2rest";
- version = lib.substring 0 10 sources.dict2rest.date;
+ version = "2016-12-05";
- src = sources.dict2rest;
+ src = fetchFromGitHub {
+ owner = "felix";
+ repo = "go-dict2rest";
+ rev = "b049991a46a2f619344bd6e915745703864d0134";
+ hash = "sha256-v5vBsdGQZYHSPEiBgSezKqaev1sTXnP27Tn47z1ebjQ=";
+ };
goPackagePath = "github.com/felix/go-dict2rest";
meta = with lib; {
- inherit (sources.dict2rest) description homepage;
+ description = "A simple proxy service providing an HTTP interface to a Dict protocol (RFC 2229) server";
+ inherit (src.meta) homepage;
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;