commit 681f46c42a0aae269509b76b530bdc79a9cac46f
parent ee56c50dc5be1dc7fe93d8000756185fc6705ad8
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 20 Oct 2024 03:51:54 +0400
Add earthaccess
Diffstat:
2 files changed, 49 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -101,6 +101,7 @@ lib.makeScope newScope (
config-path = callPackage ./development/python-modules/config-path { };
contextily = callPackage ./development/python-modules/contextily { };
curses-menu = callPackage ./development/python-modules/curses-menu { };
+ earthaccess = callPackage ./development/python-modules/earthaccess { };
earthpy = callPackage ./development/python-modules/earthpy { };
geotiler = callPackage ./development/python-modules/geotiler { };
gpxelevations = callPackage ./development/python-modules/gpxelevations { };
diff --git a/pkgs/development/python-modules/earthaccess/default.nix b/pkgs/development/python-modules/earthaccess/default.nix
@@ -0,0 +1,48 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3Packages,
+ python-cmr,
+ pqdm,
+ tinynetrc,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "earthaccess";
+ version = "0.11.0";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "nsidc";
+ repo = "earthaccess";
+ rev = "v${version}";
+ hash = "sha256-N4pRODkCPUNW3EPTLgtSscHJv4B/YN37VNOhzCC33+M=";
+ };
+
+ build-system = with python3Packages; [
+ hatchling
+ hatch-vcs
+ ];
+
+ dependencies = with python3Packages; [
+ python-cmr
+ pqdm
+ requests
+ s3fs
+ fsspec
+ tinynetrc
+ multimethod
+ importlib-resources
+ typing-extensions
+ numpy
+ ];
+
+ pythonImportsCheck = [ "earthaccess" ];
+
+ meta = {
+ description = "Client library for NASA Earthdata APIs";
+ homepage = "https://github.com/nsidc/earthaccess";
+ license = lib.licenses.mit;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}