commit 61fd0e8e9629763f126f0ef34fa1070c41059425
parent f4d7a1c13d9d5523ecca245cf3ca8bbbd071182f
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 11 Jul 2020 02:29:21 +0300
Add tilesets-cli
Diffstat:
4 files changed, 70 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -316,6 +316,20 @@
"url": "https://github.com/hfst/hfst/archive/a140e2868c15e9987d651aa3e6b344ec20ef3a33.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "jsonseq": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2019-07-31T19:44:30Z",
+ "description": "Python implementation of RFC 7464",
+ "homepage": "https://github.com/sgillies/jsonseq",
+ "owner": "sgillies",
+ "repo": "jsonseq",
+ "rev": "d9a9c86c6c05abca1ed2bdbff248eb3cd9f214fd",
+ "sha256": "0a2ivyc4dbfxnwc8phzgxxnmg57n5iwk4sjcnarhib25qkwbi6v9",
+ "type": "tarball",
+ "url": "https://github.com/sgillies/jsonseq/archive/d9a9c86c6c05abca1ed2bdbff248eb3cd9f214fd.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"libshell": {
"branch": "master",
"builtin": false,
@@ -673,6 +687,20 @@
"url": "https://github.com/selectel/supload/archive/70690682867713c68d7c6daa833a1013e79df407.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "tilesets-cli": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-06-22T23:59:51Z",
+ "description": "CLI for interacting with the Mapbox Tilesets API",
+ "homepage": "https://docs.mapbox.com/api/maps/#tilesets",
+ "owner": "mapbox",
+ "repo": "tilesets-cli",
+ "rev": "419f9f9227354ff81d5c5b7bf9d6636019d04916",
+ "sha256": "1q3xz91477il7qr3dx47f89gjb3n7lc1nd07jcvg802lrppiszzd",
+ "type": "tarball",
+ "url": "https://github.com/mapbox/tilesets-cli/archive/419f9f9227354ff81d5c5b7bf9d6636019d04916.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"tpkutils": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -91,6 +91,9 @@ lib.makeScope newScope (
gpxelevations = python3Packages.callPackage ./development/python-modules/gpxelevations {
inherit sources;
};
+ jsonseq = python3Packages.callPackage ./development/python-modules/jsonseq {
+ inherit sources;
+ };
mercantile = python3Packages.callPackage ./development/python-modules/mercantile {
inherit sources;
};
@@ -162,6 +165,9 @@ lib.makeScope newScope (
inherit sources mercantile;
};
supload = callPackage ./tools/supload { };
+ tilesets-cli = python3Packages.callPackage ./tools/geo/tilesets-cli {
+ inherit sources jsonseq;
+ };
tpkutils = python3Packages.callPackage ./tools/geo/tpkutils {
inherit sources mercantile pymbtiles;
};
diff --git a/pkgs/development/python-modules/jsonseq/default.nix b/pkgs/development/python-modules/jsonseq/default.nix
@@ -0,0 +1,17 @@
+{ lib, buildPythonPackage, sources }:
+let
+ pname = "jsonseq";
+ date = lib.substring 0 10 sources.jsonseq.date;
+ version = "unstable-" + date;
+in
+buildPythonPackage {
+ inherit pname version;
+ src = sources.jsonseq;
+
+ meta = with lib; {
+ inherit (sources.jsonseq) description homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/tools/geo/tilesets-cli/default.nix b/pkgs/tools/geo/tilesets-cli/default.nix
@@ -0,0 +1,19 @@
+{ lib, buildPythonApplication, boto3, click, cligj, requests, requests-toolbelt, jsonschema, jsonseq, sources }:
+let
+ pname = "tilesets-cli";
+ date = lib.substring 0 10 sources.tilesets-cli.date;
+ version = "unstable-" + date;
+in
+buildPythonApplication {
+ inherit pname version;
+ src = sources.tilesets-cli;
+
+ propagatedBuildInputs = [ boto3 click cligj requests requests-toolbelt jsonschema jsonseq ];
+
+ meta = with lib; {
+ inherit (sources.tilesets-cli) description homepage;
+ license = licenses.bsd2;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}