commit f4d7a1c13d9d5523ecca245cf3ca8bbbd071182f
parent 79247a51a15f94b3e1e48bfe18b2eeb30a64457a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 11 Jul 2020 01:30:17 +0300
Fix displayed version
Diffstat:
3 files changed, 9 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/gpxlab/default.nix b/pkgs/applications/gpxlab/default.nix
@@ -24,6 +24,10 @@ mkDerivation {
inherit qttranslations;
});
+ postPatch = ''
+ sed -i "s/\(VERSION = \).*/\1${version}/" GPXLab/GPXLab.pro
+ '';
+
nativeBuildInputs = [ qmake ] ++ (lib.optional withI18n qttools);
buildInputs = [ qtbase ];
diff --git a/pkgs/applications/gpxsee/default.nix b/pkgs/applications/gpxsee/default.nix
@@ -24,6 +24,10 @@ mkDerivation {
inherit qttranslations;
});
+ postPatch = ''
+ sed -i "s/\(VERSION = \).*/\1${version}/" gpxsee.pro
+ '';
+
nativeBuildInputs = [ qmake ] ++ (lib.optional withI18n qttools);
buildInputs = [ qtbase ];
diff --git a/pkgs/applications/openorienteering-mapper/default.nix b/pkgs/applications/openorienteering-mapper/default.nix
@@ -51,6 +51,7 @@ mkDerivation {
# See https://github.com/NixOS/nixpkgs/issues/85306
"-DLICENSING_PROVIDER:BOOL=OFF"
"-DMapper_MANUAL_QTHELP:BOOL=OFF"
+ "-DMapper_VERSION_DISPLAY=${version}"
] ++ lib.optionals stdenv.isDarwin [
# Usually enabled on Darwin
"-DCMAKE_FIND_FRAMEWORK=never"