commit 5f1c74dba20f5ab38495db3e3814dc6a8e2633e9
parent 75fdba8b4bbc50a9171e6fd54ac496f2f2751dce
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 24 Mar 2022 17:24:39 +0300
Up
Diffstat:
2 files changed, 13 insertions(+), 12 deletions(-)
diff --git a/pkgs/misc/libnbcompat/default.nix b/pkgs/misc/libnbcompat/default.nix
@@ -18,7 +18,6 @@ stdenv.mkDerivation rec {
inherit (src.meta) homepage;
license = licenses.free;
maintainers = [ maintainers.sikmir ];
- platforms = platforms.linux;
- skip.ci = true;
+ platforms = platforms.unix;
};
}
diff --git a/pkgs/osm/smrender/default.nix b/pkgs/osm/smrender/default.nix
@@ -1,25 +1,27 @@
-{ lib, stdenv, fetchFromGitHub, autoreconfHook269, pkg-config, cairo, librsvg }:
+{ lib, stdenv, fetchFromGitHub, autoreconfHook, pkg-config, cairo, librsvg }:
stdenv.mkDerivation rec {
pname = "smrender";
- version = "2021-03-15";
+ version = "4.3.0";
src = fetchFromGitHub {
owner = "rahra";
repo = pname;
- rev = "3c146d1dcf28d59866598a3de924dcb8b119e6df";
- hash = "sha256-tgUoSrsZWAPDPnujiB69dgSdZtPUoO9VuMgwlDfEeN0=";
+ rev = "v${version}";
+ hash = "sha256-b9xuOPLxA9zZzIwWl+FTSW5XHgJ2sFoC578ZH6iwjaM=";
};
- postPatch = ''
- substituteInPlace configure.ac \
- --replace "git log --oneline | wc -l" "echo 470"
- '';
-
- nativeBuildInputs = [ autoreconfHook269 pkg-config ];
+ nativeBuildInputs = [ autoreconfHook pkg-config ];
buildInputs = [ cairo librsvg ];
+ doInstallCheck = true;
+ installCheckPhase = ''
+ runHook preInstallCheck
+ $out/bin/smrender -v | grep "V${version}"
+ runHook postInstallCheck
+ '';
+
meta = with lib; {
description = "A powerful, flexible, and modular rule-based rendering engine for OSM data";
inherit (src.meta) homepage;