commit 75fdba8b4bbc50a9171e6fd54ac496f2f2751dce
parent 51364c63539e2080d00680372dc59849a43914ae
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 23 Mar 2022 09:49:04 +0300
Move gef to nixpkgs
See https://github.com/NixOS/nixpkgs/pull/164985
Diffstat:
2 files changed, 0 insertions(+), 63 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -279,7 +279,6 @@ lib.makeScope newScope (
docx2csv = callPackage ./misc/docx2csv { };
finalcut = callPackage ./misc/finalcut { };
gaiagpsclient = callPackage ./misc/gaiagpsclient { };
- gef = callPackage ./misc/gef { };
glauth = callPackage ./misc/glauth { };
how-to-use-pvs-studio-free = callPackage ./misc/pvs-studio/how-to-use-pvs-studio-free.nix { };
huami-token = callPackage ./misc/huami-token { };
diff --git a/pkgs/misc/gef/default.nix b/pkgs/misc/gef/default.nix
@@ -1,62 +0,0 @@
-{ lib
-, stdenv
-, fetchFromGitHub
-, runtimeShell
-, writeScript
-, procps
-, binutils-unwrapped
-, gdb
-, python3
-}:
-let
- initGef = writeScript "init-gef" ''
- source @out@/share/gef/gef.py
- '';
-
- gdbGef = writeScript "gdb-gef" (
- with lib; ''
- #!${runtimeShell}
- export PATH="${makeBinPath [ procps binutils-unwrapped python3 ]}:$PATH"
- export NIX_PYTHONPATH="${pythonPath}"
- ${gdb}/bin/gdb -x @out@/share/gef/init-gef "$@"
- ''
- );
-
- pythonPath = with python3.pkgs; makePythonPath [
- capstone
- unicorn
- ];
-in
-stdenv.mkDerivation rec {
- pname = "gef";
- version = "2021.07";
-
- src = fetchFromGitHub {
- owner = "hugsy";
- repo = pname;
- rev = version;
- hash = "sha256-zKn3yS9h8bzjsb/iPgNU8g5IgXFBaKvM7osTqzzv16s=";
- };
-
- dontBuild = true;
- doCheck = false;
-
- installPhase = ''
- install -Dm644 gef.py -t $out/share/gef
- install -Dm644 ${initGef} $out/share/gef/init-gef
- install -Dm755 ${gdbGef} $out/bin/gdb-gef
- '';
-
- postFixup = ''
- substituteInPlace $out/share/gef/init-gef --subst-var out
- substituteInPlace $out/bin/gdb-gef --subst-var out
- '';
-
- meta = with lib; {
- description = "GDB Enhanced Features for exploit devs & reversers";
- homepage = "http://gef.rtfd.io/";
- license = licenses.mit;
- platforms = platforms.all;
- maintainers = [ maintainers.sikmir ];
- };
-}