commit 5c43b46ef1fe9cf6514a50efa0f9f018eb9e0b18
parent 88afad9a8c0f2bd6c992b8333ffc1d99cfe51733
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 19 May 2024 02:24:19 +0400
Add pyarrow_ops
Diffstat:
2 files changed, 28 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -110,6 +110,7 @@ lib.makeScope newScope (
python3Packages = pkgs.python310Packages;
};
portolan = callPackage ./development/python-modules/portolan { };
+ pyarrow_ops = callPackage ./development/python-modules/pyarrow_ops { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
pytest-mp = callPackage ./development/python-modules/pytest-mp { };
pytest-shell-utilities = callPackage ./development/python-modules/pytest-shell-utilities { };
diff --git a/pkgs/development/python-modules/pyarrow_ops/default.nix b/pkgs/development/python-modules/pyarrow_ops/default.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, python3Packages, fetchFromGitHub }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "pyarrow_ops";
+ version = "0-unstable-2022-01-30";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "TomScheffers";
+ repo = "pyarrow_ops";
+ rev = "d8ee38e47ed064a5e8179d53086ac5ed67c44e6a";
+ hash = "sha256-g3dFAviGSafK2mLWgF4zhXHW8ffBnoQheeC+whAOLRY=";
+ };
+
+ build-system = with python3Packages; [ setuptools ];
+
+ nativeBuildInputs = with python3Packages; [ cython ];
+
+ propagatedBuildInputs = with python3Packages; [ numpy pyarrow ];
+
+ meta = with lib; {
+ description = "Convenient pyarrow operations following the Pandas API";
+ homepage = "https://github.com/TomScheffers/pyarrow_ops";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ };
+}