commit 88afad9a8c0f2bd6c992b8333ffc1d99cfe51733
parent a524ae2fb8eb1dca0725a4e361f8e4afc27c2988
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 19 May 2024 01:42:23 +0400
Add geoarrow-c, geoarrow-pyarrow
Diffstat:
3 files changed, 57 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -204,6 +204,8 @@ lib.makeScope newScope (
click = click-6-7;
};
garmindev = callPackage ./geospatial/qlandkartegt/garmindev.nix { };
+ geoarrow-c = callPackage ./geospatial/geoarrow-c { };
+ geoarrow-pyarrow = callPackage ./geospatial/geoarrow-pyarrow { };
geojson-pydantic = callPackage ./geospatial/geojson-pydantic { };
geowebcache = callPackage ./geospatial/geowebcache { };
go-pmtiles = callPackage ./geospatial/go-pmtiles { };
diff --git a/pkgs/geospatial/geoarrow-c/default.nix b/pkgs/geospatial/geoarrow-c/default.nix
@@ -0,0 +1,28 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "geoarrow-c";
+ version = "0.1.2";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "geoarrow";
+ repo = "geoarrow-c";
+ rev = "v${version}";
+ hash = "sha256-uEB+D3HhrjnCgExhguZkmvYzULWo5gAWxXeIGQOssqo=";
+ };
+
+ sourceRoot = "${src.name}/python/geoarrow-c";
+
+ build-system = with python3Packages; [ setuptools-scm ];
+
+ nativeBuildInputs = with python3Packages; [ cython ];
+
+ meta = with lib; {
+ description = "Experimental C and C++ implementation of the GeoArrow specification";
+ homepage = "http://geoarrow.org/geoarrow-c/";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/geospatial/geoarrow-pyarrow/default.nix b/pkgs/geospatial/geoarrow-pyarrow/default.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages, geoarrow-c }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "geoarrow-pyarrow";
+ version = "0.1.2";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "geoarrow";
+ repo = "geoarrow-python";
+ rev = "v${version}";
+ hash = "sha256-Ni+GKTRhRDRHip1us3OZPuUhHQCNU7Nap865T/+CU8Y=";
+ };
+
+ sourceRoot = "${src.name}/geoarrow-pyarrow";
+
+ build-system = with python3Packages; [ setuptools-scm ];
+
+ propagatedBuildInputs = with python3Packages; [ geoarrow-c pyarrow pyarrow-hotfix ];
+
+ meta = with lib; {
+ description = "Python implementation of the GeoArrow specification";
+ homepage = "https://github.com/geoarrow/geoarrow-python";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ };
+}