commit 5a0b55ce79133658806be909ab4d30f9f55847f1
parent 662695517c615325f7584d975372622d5d8eca44
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 28 Jan 2024 17:05:23 +0400
Up
Diffstat:
4 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/pkgs/misc/mysql-to-sqlite3/default.nix b/pkgs/misc/mysql-to-sqlite3/default.nix
@@ -2,14 +2,14 @@
python3Packages.buildPythonApplication rec {
pname = "mysql-to-sqlite3";
- version = "2.1.1";
+ version = "2.1.9";
pyproject = true;
src = fetchFromGitHub {
owner = "techouse";
repo = "mysql-to-sqlite3";
rev = "v${version}";
- hash = "sha256-MXOkR7eDxCtRptEYPrkmtpkxyQh/RfNAzb7MKYt8p20=";
+ hash = "sha256-nS+BWVemB1XYe37+Cl8q8ZhXBcZDBw5ApOapns7hXKg=";
};
nativeBuildInputs = with python3Packages; [ hatchling ];
@@ -31,5 +31,6 @@ python3Packages.buildPythonApplication rec {
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
mainProgram = "mysql2sqlite";
+ broken = true; # required mysql-connector-python>=8.2.0
};
}
diff --git a/pkgs/mqtt/influxdb-cxx/default.nix b/pkgs/mqtt/influxdb-cxx/default.nix
@@ -26,6 +26,7 @@ stdenv.mkDerivation (finalAttrs: {
cmakeFlags = [
(lib.cmakeBool "INFLUXCXX_TESTING" finalAttrs.doCheck)
+ (lib.cmakeFeature "CMAKE_CTEST_ARGUMENTS" "-E;BoostSupportTest") # requires network access
];
doCheck = true;
diff --git a/pkgs/osm/taginfo-tools/default.nix b/pkgs/osm/taginfo-tools/default.nix
@@ -25,5 +25,6 @@ stdenv.mkDerivation {
license = licenses.gpl3Plus;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
+ broken = stdenv.isLinux;
};
}
diff --git a/pkgs/radio/goestools/default.nix b/pkgs/radio/goestools/default.nix
@@ -12,6 +12,11 @@ stdenv.mkDerivation rec {
fetchSubmodules = true;
};
+ postPatch = ''
+ sed -i '8i #include <cstdint>' src/dcs/dcs.h
+ sed -i '4i #include <cstdint>' src/assembler/vcdu.h
+ '';
+
nativeBuildInputs = [ cmake pkg-config ];
buildInputs = [ opencv4 rtl-sdr zlib ];