commit 5563930d7d4074c38caf09cce525e48c23fa7147
parent 58c3af9df27693e182566dcf1a23e336e1335a0c
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 22 May 2021 13:38:59 +0300
Move gpxlab to nixpkgs
Diffstat:
4 files changed, 0 insertions(+), 83 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -1,18 +1,4 @@
{
- "gpxlab": {
- "branch": "master",
- "builtin": false,
- "date": "2020-10-16T17:00:40Z",
- "description": "Program to show and manipulate GPS tracks",
- "homepage": "https://github.com/BourgeoisLab/GPXLab",
- "owner": "BourgeoisLab",
- "repo": "GPXLab",
- "rev": "0a2e13756ed1c39f4278b0b3d6cef7f8ac9f6fe7",
- "sha256": "1z4wdnd65gkzpbn1gqrsl6vs0gvc9pqgnziw19g6bhap41dvxbv0",
- "type": "tarball",
- "url": "https://github.com/BourgeoisLab/GPXLab/archive/0a2e13756ed1c39f4278b0b3d6cef7f8ac9f6fe7.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"map-hr": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/applications/gpxlab/default.nix b/pkgs/applications/gpxlab/default.nix
@@ -1,49 +0,0 @@
-{ stdenv
-, mkDerivation
-, lib
-, qmake
-, qtbase
-, qttools
-, qttranslations
-, sources
-, substituteAll
-, withI18n ? true
-}:
-
-mkDerivation rec {
- pname = "gpxlab-unstable";
- version = lib.substring 0 10 sources.gpxlab.date;
-
- src = sources.gpxlab;
-
- patches = (substituteAll {
- # See https://github.com/NixOS/nixpkgs/issues/86054
- src = ./fix-qttranslations-path.patch;
- inherit qttranslations;
- });
-
- postPatch = ''
- sed -i "s/\(VERSION = \).*/\1${version}/" GPXLab/GPXLab.pro
- '';
-
- nativeBuildInputs = [ qmake ] ++ (lib.optional withI18n qttools);
-
- preConfigure = lib.optionalString withI18n ''
- lrelease GPXLab/locale/*.ts
- '';
-
- postInstall = lib.optionalString stdenv.isDarwin ''
- mkdir -p $out/Applications
- mv GPXLab/GPXLab.app $out/Applications
- wrapQtApp $out/Applications/GPXLab.app/Contents/MacOS/GPXLab
- mkdir -p $out/bin
- ln -s $out/Applications/GPXLab.app/Contents/MacOS/GPXLab $out/bin/gpxlab
- '';
-
- meta = with lib; {
- inherit (sources.gpxlab) description homepage;
- license = licenses.gpl3;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}
diff --git a/pkgs/applications/gpxlab/fix-qttranslations-path.patch b/pkgs/applications/gpxlab/fix-qttranslations-path.patch
@@ -1,17 +0,0 @@
-diff --git i/GPXLab/main.cpp w/GPXLab/main.cpp
-index b12d2dd..58d37c5 100644
---- i/GPXLab/main.cpp
-+++ w/GPXLab/main.cpp
-@@ -19,10 +19,10 @@ int main(int argc, char *argv[])
- app.installTranslator(&gpxlab);
-
- QTranslator qt;
--#if defined(Q_OS_WIN32) || defined(Q_OS_MAC)
-+#if defined(Q_OS_WIN32)
- qt.load(QLocale::system(), "qt", "_", TRANSLATIONS_DIR);
- #else
-- qt.load(QLocale::system(), "qt", "_", QLibraryInfo::location(QLibraryInfo::TranslationsPath));
-+ qt.load(QLocale::system(), "qt", "_", QLatin1String("@qttranslations@/translations"));
- #endif
- app.installTranslator(&qt);
-
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -9,9 +9,6 @@ lib.makeScope newScope (
### APPLICATIONS
goldencheetah-bin = callPackage ./applications/goldencheetah/bin.nix { };
- gpxlab = libsForQt5.callPackage ./applications/gpxlab {
- inherit sources;
- };
gpxsee-bin = callPackage ./applications/gpxsee/bin.nix { };
i18n-editor-bin = callPackage ./applications/i18n-editor { jre = pkgs.jdk11; };
iterm2-bin = callPackage ./applications/iterm2/bin.nix { };