commit 58c3af9df27693e182566dcf1a23e336e1335a0c
parent 5b331f6663dd24bbf1715d6d4ab7cc6b3fe9cc49
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 22 May 2021 13:11:13 +0300
Remove fx-bin
Diffstat:
2 files changed, 0 insertions(+), 52 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -115,7 +115,6 @@ lib.makeScope newScope (
elevation = callPackage ./tools/geo/elevation {
click = click-6-7;
};
- fx-bin = callPackage ./tools/text/fx/bin.nix { };
go-staticmaps = callPackage ./tools/geo/go-staticmaps { };
gpx-interpolate = callPackage ./tools/geo/gpx-interpolate { };
gpx-layer = perlPackages.callPackage ./tools/geo/gpx-layer { };
diff --git a/pkgs/tools/text/fx/bin.nix b/pkgs/tools/text/fx/bin.nix
@@ -1,51 +0,0 @@
-{ lib, stdenv, fetchfromgh, unzip }:
-let
- pname = "fx";
- version = "18.0.1";
-
- inherit (stdenv.hostPlatform) system;
- throwSystem = throw "Unsupported system: ${system}";
-
- suffix = {
- x86_64-linux = "linux";
- x86_64-darwin = "macos";
- }.${system} or throwSystem;
-in
-stdenv.mkDerivation {
- inherit pname version;
-
- src = fetchfromgh {
- inherit version;
- owner = "antonmedv";
- repo = "fx";
- name = "fx-${suffix}.zip";
- sha256 = {
- x86_64-linux = "1q46qidyg6jmk1f74rp2yaqqpg8yzzrw2vmpm2djyiszsqsakfbz";
- x86_64-darwin = "1mcclxn6hw1b8z47kdp26kybk03b59llfgamp425nni0mi5vzrm0";
- }.${system} or throwSystem;
- };
-
- dontConfigure = true;
- dontBuild = true;
- dontStrip = true;
-
- unpackPhase = "${unzip}/bin/unzip $src";
-
- installPhase = "install -Dm755 fx-${suffix} $out/bin/fx";
-
- postFixup = lib.optionalString stdenv.isLinux ''
- patchelf \
- --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) \
- --set-rpath "${lib.makeLibraryPath [ stdenv.cc.cc.lib ]}" \
- $out/bin/fx
- '';
-
- meta = with lib; {
- description = "Command-line tool and terminal JSON viewer";
- homepage = "https://github.com/antonmedv/fx";
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = [ "x86_64-linux" "x86_64-darwin" ];
- skip.ci = true;
- };
-}