commit 54b4a1e2529e401b5788ff6295c7820f56d0a647
parent d6bc26cec9570136a07564aea10568040fc7dd55
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 27 Jan 2024 21:16:05 +0400
Add zed
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/zed/default.nix b/pkgs/darwin/zed/default.nix
@@ -0,0 +1,34 @@
+{ lib, stdenvNoCC, fetchurl, _7zz }:
+
+stdenvNoCC.mkDerivation (finalAttrs: {
+ pname = "zed";
+ version = "0.119.20";
+
+ src = fetchurl {
+ url = "https://zed.dev/api/releases/stable/${finalAttrs.version}/Zed.dmg";
+ hash = "sha256-BOb23vuupsxRnt6B4rnYy/ilGBdPaMeiJlGcRJS4Du0=";
+ };
+
+ sourceRoot = ".";
+
+ # APFS format is unsupported by undmg
+ nativeBuildInputs = [ _7zz ];
+ unpackCmd = "7zz x $curSrc";
+
+ installPhase = ''
+ runHook preInstall
+ mkdir -p $out/Applications
+ cp -r *.app $out/Applications
+ runHook postInstall
+ '';
+
+ meta = with lib; {
+ description = "High-performance, multiplayer code editor";
+ homepage = "https://zed.dev";
+ sourceProvenance = with sourceTypes; [ binaryNativeCode ];
+ license = licenses.free;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -42,6 +42,7 @@ lib.makeScope newScope (
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sequel-ace = callPackage ./darwin/sequel-ace { };
sloth = callPackage ./darwin/sloth { };
+ zed = callPackage ./darwin/zed { };
### DATA