commit 4af8d8e4ada510217d6bf7c9a8159ce4f2daaee1
parent 5aefba20ed2248e9556bd6cdbf6657ba79f8a28b
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 20 Jan 2024 20:20:24 +0400
Add python-periphery
Diffstat:
2 files changed, 23 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -113,6 +113,7 @@ lib.makeScope newScope (
pytest-mp = callPackage ./development/python-modules/pytest-mp { };
pytest-shell-utilities = callPackage ./development/python-modules/pytest-shell-utilities { };
pytest-skip-markers = callPackage ./development/python-modules/pytest-skip-markers { };
+ python-periphery = callPackage ./development/python-modules/python-periphery { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
### EMBEDDED
diff --git a/pkgs/development/python-modules/python-periphery/default.nix b/pkgs/development/python-modules/python-periphery/default.nix
@@ -0,0 +1,22 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "python-periphery";
+ version = "2.4.1";
+
+ src = fetchFromGitHub {
+ owner = "vsergeev";
+ repo = "python-periphery";
+ rev = "v${version}";
+ hash = "sha256-vRK1jeLG+z+yOYGGACO6dYSpzfO9NhNiThVTt35maaU=";
+ };
+
+ meta = with lib; {
+ description = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ skip.ci = stdenv.isDarwin;
+ };
+}