commit 363dde6e1c9cea916a3eba8e53c47b9980d1426b
parent 5563930d7d4074c38caf09cce525e48c23fa7147
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 22 May 2021 14:46:20 +0300
Up
Diffstat:
6 files changed, 28 insertions(+), 42 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -26,30 +26,5 @@
"type": "tarball",
"url": "https://github.com/slazav/map_podm/archive/c95a381155986f9f621e5d26b21bda041ad8c24f.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
- "maptourist": {
- "builtin": false,
- "description": "Ежедневная сборка карт из данных OpenStreetMap для навигационных приборов и приложений Garmin",
- "homepage": "https://maptourist.org",
- "region": "szfo",
- "sha256": "1447yna1gqmpb5zcg61f3vyw9hfv5v7dbwjh6c05lhpjf5aw6d45",
- "type": "file",
- "url": "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-szfo-RU_2021-03-06.zip",
- "url_template": "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-<region>-RU_<version>.zip",
- "version": "2021-03-06"
- },
- "odict": {
- "branch": "master",
- "builtin": false,
- "date": "2021-01-08T22:22:26Z",
- "description": "A blazingly-fast replacement for Apple Dictionaries, Babylon, StarDict, etc",
- "homepage": "https://odict.org",
- "owner": "odict",
- "repo": "odict",
- "rev": "639dbab4feac15c4f69049bfb9b7bcfecaf68b47",
- "sha256": "1ffkj7ry1rcljkilfnwffpqz3mb9ci9y9z9z6z6yhwakq4g5dj3j",
- "type": "tarball",
- "url": "https://github.com/odict/odict/archive/639dbab4feac15c4f69049bfb9b7bcfecaf68b47.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
}
}
diff --git a/pkgs/data/maps/maptourist/default.nix b/pkgs/data/maps/maptourist/default.nix
@@ -1,10 +1,13 @@
-{ lib, stdenvNoCC, sources, unzip }:
+{ lib, stdenvNoCC, fetchurl, unzip }:
-stdenvNoCC.mkDerivation {
+stdenvNoCC.mkDerivation rec {
pname = "maptourist";
- version = sources.maptourist.version;
+ version = "2021-05-21";
- src = sources.maptourist;
+ src = fetchurl {
+ url = "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-szfo-RU_${version}.zip";
+ hash = "sha256-a9iDeUWz3dwcXBk6HrIyS2+mAjkrVG6i89wKHfW+yaQ=";
+ };
sourceRoot = ".";
@@ -15,7 +18,8 @@ stdenvNoCC.mkDerivation {
preferLocalBuild = true;
meta = with lib; {
- inherit (sources.maptourist) description homepage;
+ description = "Ежедневная сборка карт из данных OpenStreetMap для навигационных приборов и приложений Garmin";
+ homepage = "https://maptourist.org";
license = licenses.free;
maintainers = [ maintainers.sikmir ];
platforms = platforms.all;
diff --git a/pkgs/development/python-modules/rasterio/default.nix b/pkgs/development/python-modules/rasterio/default.nix
@@ -1,8 +1,9 @@
-{ lib, fetchFromGitHub, python3Packages, gdal }:
+{ lib, fetchFromGitHub, python3Packages, pythonOlder, gdal }:
python3Packages.buildPythonPackage rec {
pname = "rasterio";
version = "1.2.3";
+ disabled = pythonOlder "3.6";
src = fetchFromGitHub {
owner = "mapbox";
@@ -15,12 +16,12 @@ python3Packages.buildPythonPackage rec {
propagatedBuildInputs = with python3Packages; [ affine attrs boto3 click-plugins cligj matplotlib numpy snuggs setuptools ];
- checkInputs = with python3Packages; [ pytestCheckHook hypothesis ];
+ checkInputs = with python3Packages; [ pytestCheckHook hypothesis shapely ];
installCheckPhase = "$out/bin/rio --version";
meta = with lib; {
- description = "Rasterio reads and writes geospatial raster datasets";
+ description = "Python package to read and write geospatial raster data";
homepage = "https://rasterio.readthedocs.io/";
license = licenses.bsd3;
maintainers = [ maintainers.sikmir ];
diff --git a/pkgs/dict/odict/default.nix b/pkgs/dict/odict/default.nix
@@ -1,15 +1,21 @@
-{ lib, buildGoModule, sources }:
+{ lib, fetchFromGitHub, buildGoModule }:
-buildGoModule {
- pname = "odict-unstable";
- version = lib.substring 0 10 sources.odict.date;
+buildGoModule rec {
+ pname = "odict";
+ version = "2021-01-08";
- src = sources.odict;
+ src = fetchFromGitHub {
+ owner = "TheOpenDictionary";
+ repo = pname;
+ rev = "639dbab4feac15c4f69049bfb9b7bcfecaf68b47";
+ hash = "sha256-cshWHsFTcejNNz/95FNkadXx8XWOW0fjlJTl4POR07k=";
+ };
- vendorSha256 = "1n07b9dclsyc0m50lifigm90k3l6s1kbx6fln4gzp4crn0axh0gs";
+ vendorSha256 = "sha256-+gHYFbCZkfsfsdSZvmbQho4JUn3RRQpKBcxrylpaB9g=";
meta = with lib; {
- inherit (sources.odict) description homepage;
+ description = "A blazingly-fast portable dictionary file format";
+ homepage = "https://odict.org/";
license = licenses.gpl3;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
diff --git a/pkgs/dict/opendict/default.nix b/pkgs/dict/opendict/default.nix
@@ -1,4 +1,4 @@
-{ lib, fetchFromGitHub, python2Packages, gettext, sources }:
+{ lib, fetchFromGitHub, python2Packages, gettext }:
python2Packages.buildPythonApplication rec {
pname = "opendict";
diff --git a/pkgs/osm/taginfo-tools/default.nix b/pkgs/osm/taginfo-tools/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchFromGitHub, cmake, bzip2, expat, gd, icu, libosmium, protozero, sqlite, zlib, sources }:
+{ lib, stdenv, fetchFromGitHub, cmake, bzip2, expat, gd, icu, libosmium, protozero, sqlite, zlib }:
stdenv.mkDerivation rec {
pname = "taginfo-tools";