commit 2fb19a78cd1537304fc2cd420211a94fc02b1c94
parent 57172674080940ca57c44a93f5ea30ad13212975
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 22 Sep 2024 14:42:18 +0400
Cleanup
Diffstat:
12 files changed, 12 insertions(+), 36 deletions(-)
diff --git a/pkgs/geospatial/rio-mbtiles/default.nix b/pkgs/geospatial/rio-mbtiles/default.nix
@@ -16,11 +16,6 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-Kje443Qqs8+Jcv3PnTrMncaoaGDdjrzTcd42NYIenuU=";
};
- postPatch = ''
- substituteInPlace setup.py \
- --replace-fail "shapely~=1.7.0" "shapely"
- '';
-
dependencies = with python3Packages; [
click
cligj
diff --git a/pkgs/geospatial/tilecloud/default.nix b/pkgs/geospatial/tilecloud/default.nix
@@ -17,16 +17,18 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-yblAOBp9anvsVnF9q8jwnMoyNG42K+E3antBe5pkS7Y=";
};
+ pythonRelaxDeps = [
+ "pillow"
+ "webob"
+ ];
+
patches = [ ./set-tmpl-path.patch ];
postPatch = ''
substituteInPlace pyproject.toml \
--replace-fail "\"poetry-plugin-drop-python-upper-constraint\"" "" \
--replace-fail "\"poetry-plugin-tweak-dependencies-version\"," "" \
- --replace-fail "\"poetry-plugin-tweak-dependencies-version>=1.1.0\"," "" \
- --replace-fail "requests = \"2.32.3\"" "requests = \"*\"" \
- --replace-fail "Pillow = \"10.3.0\"" "Pillow = \"*\"" \
- --replace-fail "webob = \"1.8.8\"" "webob = \"*\""
+ --replace-fail "\"poetry-plugin-tweak-dependencies-version>=1.1.0\"," ""
'';
build-system = with python3Packages; [
diff --git a/pkgs/geospatial/tilesets-cli/default.nix b/pkgs/geospatial/tilesets-cli/default.nix
@@ -19,8 +19,6 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-ZAPoHtrUA+D1mjWGJ/YvErYmWiXMS+tsPG+CokB9Iy8=";
};
- postPatch = "sed -i 's/~=.*\"/\"/' setup.py";
-
dependencies = with python3Packages; [
boto3
click
diff --git a/pkgs/gnss/pygnssutils/default.nix b/pkgs/gnss/pygnssutils/default.nix
@@ -18,11 +18,6 @@ python3Packages.buildPythonPackage rec {
hash = "sha256-FCLvqs0B33WWN0F41X7PvdMSab9JwpJDFB6ycy/R6G8=";
};
- postPatch = ''
- substituteInPlace pyproject.toml \
- --replace-fail "certifi>=2024.0.0" "certifi"
- '';
-
build-system = with python3Packages; [ setuptools ];
dependencies = with python3Packages; [
diff --git a/pkgs/gpx/gpxtrackposter/default.nix b/pkgs/gpx/gpxtrackposter/default.nix
@@ -33,7 +33,6 @@ python3Packages.buildPythonApplication {
--replace-fail "from stravalib.model import Activity" "from stravalib.model import DetailedActivity"
substituteInPlace gpxtrackposter/cli.py \
--subst-var out
- sed -i 's/~=.*//' requirements.txt
'';
dependencies = with python3Packages; [
diff --git a/pkgs/linguistics/tatoebatools/default.nix b/pkgs/linguistics/tatoebatools/default.nix
@@ -21,8 +21,6 @@ python3Packages.buildPythonApplication rec {
lib.optional (!checkLang) ./dont-check-lang-validity.patch
++ lib.optional withCli ./cli.patch;
- postPatch = "sed -i 's/==.*\"/\"/;s/>=.*\"/\"/' setup.py";
-
dependencies =
with python3Packages;
[
diff --git a/pkgs/linguistics/zdict/default.nix b/pkgs/linguistics/zdict/default.nix
@@ -21,8 +21,6 @@ python3Packages.buildPythonApplication rec {
requests
];
- postPatch = "sed -i 's/==.*//' requirements.txt";
-
doCheck = false;
meta = {
diff --git a/pkgs/misc/huami-token/default.nix b/pkgs/misc/huami-token/default.nix
@@ -17,9 +17,10 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-nQiz1vrZz0sOoZFQaN9ZtzfDY3zn3Gk0jMdqORDDW3w=";
};
- postPatch = ''
- substituteInPlace pyproject.toml --replace "requests == 2.25.1" "requests"
- '';
+ pythonRelaxDeps = [
+ "requests"
+ "types-requests"
+ ];
build-system = with python3Packages; [ flit ];
diff --git a/pkgs/misc/modbus_sim_cli/default.nix b/pkgs/misc/modbus_sim_cli/default.nix
@@ -17,7 +17,7 @@ python3Packages.buildPythonApplication {
};
postPatch = ''
- sed -i 's/==.*//;/trollius/d' requirements
+ sed -i '/trollius/d' requirements
substituteInPlace modbus_sim/utils/config_parser.py \
--replace-fail "yaml.load(conffile.read())" "yaml.safe_load(conffile)"
'';
diff --git a/pkgs/misc/telegram-send/default.nix b/pkgs/misc/telegram-send/default.nix
@@ -16,11 +16,6 @@ python3Packages.buildPythonApplication {
hash = "sha256-DeEz1cVor2GBoQrDIHNWr5IYnPgBsTWr5xMuSM38MBw=";
};
- postPatch = ''
- substituteInPlace setup.py \
- --replace-fail "python-telegram-bot==20.6" "python-telegram-bot"
- '';
-
nativeBuildInputs = with python3Packages; [ pip ];
dependencies = with python3Packages; [
diff --git a/pkgs/mqtt/mqtt-logger/default.nix b/pkgs/mqtt/mqtt-logger/default.nix
@@ -16,10 +16,7 @@ python3Packages.buildPythonPackage rec {
hash = "sha256-AG8L2CD+YN6gWswDtsUtUMOA3xC2ro1f1YKYgc4jwXE=";
};
- postPatch = ''
- sed -i 's/==.*//' requirements.txt
- sed -i 's/rich = "^12.0.0"/rich = "*"/' pyproject.toml
- '';
+ pythonRelaxDeps = [ "rich" ];
build-system = with python3Packages; [ poetry-core ];
diff --git a/pkgs/osm/prettymapp/default.nix b/pkgs/osm/prettymapp/default.nix
@@ -16,8 +16,6 @@ python3Packages.buildPythonPackage rec {
hash = "sha256-6UO2+pvtm3t6LjC2v91NJVLVo74Bdx1xzpHqvL15UCg=";
};
- postPatch = "sed -i 's/==.*//' requirements.txt";
-
dependencies = with python3Packages; [ osmnx ];
nativeCheckInputs = with python3Packages; [