commit 2b32aa07fa0e70e3fdbeb22250b5e2cb471e9369
parent 5daee349b3c517a79221c3ac387d0d2604584dc5
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 6 Sep 2024 16:55:58 +0400
Move osm-python-tools to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 51 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -461,7 +461,6 @@ lib.makeScope newScope (
memphis = callPackage ./osm/memphis { };
osm-3s = callPackage ./osm/osm-3s { };
osm-area-tools = callPackage ./osm/osm-area-tools { };
- osm-python-tools = callPackage ./osm/osm-python-tools { };
osm-tags-transform = callPackage ./osm/osm-tags-transform { };
osm2geojson = callPackage ./osm/osm2geojson { };
osmcoastline = callPackage ./osm/osmcoastline { };
diff --git a/pkgs/osm/osm-python-tools/default.nix b/pkgs/osm/osm-python-tools/default.nix
@@ -1,50 +0,0 @@
-{
- lib,
- stdenv,
- python3Packages,
- fetchFromGitHub,
-}:
-
-python3Packages.buildPythonPackage rec {
- pname = "osm-python-tools";
- version = "0.3.5";
-
- src = fetchFromGitHub {
- owner = "mocnik-science";
- repo = "osm-python-tools";
- rev = "v${version}";
- hash = "sha256-lTDA1Rad9aYI/ymU/0xzdJHmebUGcpVJ0GW7D0Ujdko=";
- };
-
- postPatch = ''
- substituteInPlace setup.py \
- --replace-fail "'pytest" "#'pytest" \
- '';
-
- dependencies = with python3Packages; [
- beautifulsoup4
- geojson
- lxml
- matplotlib
- numpy
- pandas
- ujson
- xarray
- ];
-
- doCheck = false;
-
- pythonImportsCheck = [
- "OSMPythonTools.api"
- "OSMPythonTools.data"
- "OSMPythonTools.nominatim"
- "OSMPythonTools.overpass"
- ];
-
- meta = {
- description = "A library to access OpenStreetMap related services";
- homepage = "https://github.com/mocnik-science/osm-python-tools";
- license = lib.licenses.gpl3;
- maintainers = [ lib.maintainers.sikmir ];
- };
-}