commit 5daee349b3c517a79221c3ac387d0d2604584dc5
parent 2bdf040a652010f0531cfb7149056b3878476e25
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 5 Sep 2024 22:45:04 +0400
Up
Diffstat:
3 files changed, 10 insertions(+), 77 deletions(-)
diff --git a/pkgs/nakarte/elevation_server/default.nix b/pkgs/nakarte/elevation_server/default.nix
@@ -2,22 +2,22 @@
lib,
stdenv,
fetchFromGitHub,
- buildGoPackage,
+ buildGoModule,
lz4,
}:
-buildGoPackage rec {
+buildGoModule rec {
pname = "elevation_server";
version = "1.2.0";
src = fetchFromGitHub {
- owner = "wladich";
+ owner = "sikmir";
repo = "elevation_server";
- rev = version;
- hash = "sha256-2mpBboPKIV+Wm2p3FHy3a+6H3+qJUOu2+F28MufzBwU=";
+ rev = "d8964ed01e81dea4bcd20cf6f7e092da4b2d5547";
+ hash = "sha256-nckgsaXtLd1D3gYqdAMF5VRRM4zkw4G6R0P//G9lqDM=";
};
- goPackagePath = "github.com/wladich/elevation_server";
+ vendorHash = "sha256-j43mafIXC1C4RvVIoqTV44kWSJgv1WDRphX3/G29Uxk=";
subPackages = [
"cmd/elevation_server"
@@ -26,14 +26,12 @@ buildGoPackage rec {
buildInputs = [ lz4 ];
- goDeps = ./deps.nix;
-
meta = {
description = "The server providing elevation data";
homepage = "https://github.com/wladich/elevation_server";
license = lib.licenses.free;
maintainers = [ lib.maintainers.sikmir ];
platforms = lib.platforms.unix;
- broken = stdenv.isDarwin;
+ mainProgram = "elevation_server";
};
}
diff --git a/pkgs/nakarte/elevation_server/deps.nix b/pkgs/nakarte/elevation_server/deps.nix
@@ -1,65 +0,0 @@
-[
- {
- goPackagePath = "github.com/cheggaaa/pb";
- fetch = {
- type = "git";
- url = "https://github.com/cheggaaa/pb";
- rev = "f53c49a21d379f442c3b8f3f6e6adf7a0a01e438";
- sha256 = "111n0pn1mc3qfdkvl4by82zxxr8n6v8pshh5nd2kg9ij5ayrc61k";
- };
- }
- {
- goPackagePath = "github.com/mattn/go-runewidth";
- fetch = {
- type = "git";
- url = "https://github.com/mattn/go-runewidth";
- rev = "14e809f6d78fcf9f48ff9b70981472b64c05f754";
- sha256 = "1mvlxcdwr0vwp8b2wqs6y7hk72y28sqh03dz5x0xkg48d4y9cplj";
- };
- }
- {
- goPackagePath = "golang.org/x/sys";
- fetch = {
- type = "git";
- url = "https://go.googlesource.com/sys";
- rev = "f84b799fce68db3cb46a8f6f819c1e56377181df";
- sha256 = "1dvhqian5byzkcg1bnqzygqa6ccc6krc2q7j12pp1vhl3y7znnsg";
- };
- }
- {
- goPackagePath = "github.com/VividCortex/ewma";
- fetch = {
- type = "git";
- url = "https://github.com/VividCortex/ewma";
- rev = "41f1bc0f7cb2f39d665ca5735fb093191d9252d0";
- sha256 = "17gl3dcnbba3srasbwr2jmwjg6rh1msm1zi3cjichpi9fdvrdj40";
- };
- }
- {
- goPackagePath = "github.com/fatih/color";
- fetch = {
- type = "git";
- url = "https://github.com/fatih/color";
- rev = "bc2269661d49c6c9d0e514eef49710556883f3fa";
- sha256 = "1azg1r8ifnr1pk5lvqkpcssqb7s7hs0zym1fmg0k67p842bvm2n8";
- };
- }
- {
- goPackagePath = "github.com/mattn/go-colorable";
- fetch = {
- type = "git";
- url = "https://github.com/mattn/go-colorable";
- rev = "f6c00982823144337e56cdb71c712eaac151d29c";
- sha256 = "08y5c01bvyqxraj3wc0di80gbp87178rsshb74x0p3m7wwfv82l3";
- };
- }
- {
- goPackagePath = "github.com/mattn/go-isatty";
- fetch = {
- type = "git";
- url = "https://github.com/mattn/go-isatty";
- rev = "cb30d6282491c185f77d9bec5d25de1bb61a06bc";
- sha256 = "0v59mv94acd2m72q8adhigxkx1vn38l5h0d8hp0nxga2v9f3v8kd";
- };
- }
-]
diff --git a/pkgs/radio/adsb_deku/default.nix b/pkgs/radio/adsb_deku/default.nix
@@ -7,16 +7,16 @@
rustPlatform.buildRustPackage rec {
pname = "adsb_deku";
- version = "2023.11.22";
+ version = "2024.09.02";
src = fetchFromGitHub {
owner = "rsadsb";
repo = "adsb_deku";
rev = "v${version}";
- hash = "sha256-vreda3+c0HS0+YaQZrJRBdbtQgKxw+NgkSMkDqhc+AM=";
+ hash = "sha256-+WUG/CQ/j3muYow2FMFNUgWWhOCPZc0k+okoF1p1L5Y=";
};
- cargoHash = "sha256-0ur+GNJna56eM99nwJHJJlAaP60lgXSTBFHZ9NHIau8=";
+ cargoHash = "sha256-uiv8XdI/PkeeqlTX3pMCvSAgxTpnZlYExY1MPcNS0S8=";
meta = {
description = "Rust ADS-B decoder + tui radar application";