commit 23639f6eaafda83d7cbaf2b8639f879b5ffa339f
parent 9ca765969efb346c04163eebcb35c437c395e3b7
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 28 Nov 2020 22:43:12 +0300
Add bson
Diffstat:
3 files changed, 32 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -1,4 +1,18 @@
{
+ "bson": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-05-26T11:13:32Z",
+ "description": "Independent BSON codec for Python that doesn't depend on MongoDB",
+ "homepage": "https://github.com/py-bson/bson",
+ "owner": "py-bson",
+ "repo": "bson",
+ "rev": "a68073661c637051985f3d0c24b8c7828a4c3ff4",
+ "sha256": "0gh0kbblmxnidr9xp05d8nlfjna7461bxx82l82mwwz1a7i7x36d",
+ "type": "tarball",
+ "url": "https://github.com/py-bson/bson/archive/a68073661c637051985f3d0c24b8c7828a4c3ff4.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"cfiles": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -118,6 +118,7 @@ lib.makeScope newScope (
### DEVELOPMENT / PYTHON MODULES
+ bson = callPackage ./development/python-modules/bson { };
cheetah3 = callPackage ./development/python-modules/cheetah3 { };
click-6-7 = callPackage ./development/python-modules/click { };
gpxelevations = callPackage ./development/python-modules/gpxelevations { };
diff --git a/pkgs/development/python-modules/bson/default.nix b/pkgs/development/python-modules/bson/default.nix
@@ -0,0 +1,17 @@
+{ lib, python3Packages, sources }:
+
+python3Packages.buildPythonPackage {
+ pname = "bson-unstable";
+ version = lib.substring 0 10 sources.bson.date;
+
+ src = sources.bson;
+
+ propagatedBuildInputs = with python3Packages; [ python-dateutil six ];
+
+ meta = with lib; {
+ inherit (sources.bson) description homepage;
+ license = with licenses; [ bsd3 asl20 ];
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}