commit 9ca765969efb346c04163eebcb35c437c395e3b7
parent 51a251ceaf2247b63e433dd08457276bb4cd830c
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 28 Nov 2020 22:12:53 +0300
Add lazyscraper
Diffstat:
3 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -514,6 +514,20 @@
"url": "https://github.com/variar/klogg/archive/adb1eafb92bdbf27da53c1579239988b26e6882a.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "lazyscraper": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-05-19T11:50:13Z",
+ "description": "Lazy helper tool to make easier scraping with simple tasks",
+ "homepage": "https://github.com/ivbeg/lazyscraper",
+ "owner": "ivbeg",
+ "repo": "lazyscraper",
+ "rev": "2e14bd829311cde19ef32d7f0e11c3c4a3c08e1b",
+ "sha256": "02pix53f5j6g4vv2w7vj93jk6a10wld7kk6ichc04aacwq3ljy42",
+ "type": "tarball",
+ "url": "https://github.com/ivbeg/lazyscraper/archive/2e14bd829311cde19ef32d7f0e11c3c4a3c08e1b.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"libshell": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -162,6 +162,7 @@ lib.makeScope newScope (
gurl = callPackage ./tools/networking/gurl { };
imgdecode = callPackage ./tools/geo/imgdecode { };
ish = callPackage ./tools/networking/ish { };
+ lazyscraper = callPackage ./tools/text/lazyscraper { };
lsdreader = callPackage ./tools/dict/lsdreader { };
map-tiler = callPackage ./tools/geo/map-tiler { };
morse-talk = callPackage ./tools/morse-talk { };
diff --git a/pkgs/tools/text/lazyscraper/default.nix b/pkgs/tools/text/lazyscraper/default.nix
@@ -0,0 +1,19 @@
+{ lib, python3Packages, sources }:
+
+python3Packages.buildPythonApplication {
+ pname = "lazyscraper-unstable";
+ version = lib.substring 0 10 sources.lazyscraper.date;
+
+ src = sources.lazyscraper;
+
+ propagatedBuildInputs = with python3Packages; [ click lxml requests ];
+
+ postInstall = "mv $out/bin/lscraper.py $out/bin/lscraper";
+
+ meta = with lib; {
+ inherit (sources.lazyscraper) description homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}