commit 1e9303ea55f3c9f5b8dba3ff84072888ef3e9653
parent c814dfa78c8c50d0a173a739d730858364d2318c
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 1 Jan 2020 03:03:33 +0300
Add mercantile
Diffstat:
3 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -75,6 +75,9 @@ in rec {
mbutil = python3Packages.callPackage ./pkgs/mbutil {
inherit (sources) mbutil;
};
+ mercantile = python3Packages.callPackage ./pkgs/mercantile {
+ inherit (sources) mercantile;
+ };
openorienteering-mapper = libsForQt5.callPackage ./pkgs/openorienteering-mapper {
inherit (sources) mapper;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -227,6 +227,18 @@
"url": "https://github.com/mapbox/mbutil/archive/2fc4161f9be890a65d07f5e7b2ed0c8a0a123ed6.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "mercantile": {
+ "branch": "master",
+ "description": "Spherical mercator tile and coordinate utilities",
+ "homepage": "https://github.com/mapbox/mercantile",
+ "owner": "mapbox",
+ "repo": "mercantile",
+ "rev": "dae32795f9da7a9f39d8ea52f2321af008f35ab9",
+ "sha256": "1f3gw512396v5lljkn9czsln8qciccg7mm6bvv5qxggf8ih6vgya",
+ "type": "tarball",
+ "url": "https://github.com/mapbox/mercantile/archive/dae32795f9da7a9f39d8ea52f2321af008f35ab9.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"pymbtiles": {
"branch": "master",
"description": "Python utilities for Mapbox mbtiles files",
diff --git a/pkgs/mercantile/default.nix b/pkgs/mercantile/default.nix
@@ -0,0 +1,20 @@
+{ lib, buildPythonPackage, click, pytest, mercantile }:
+
+buildPythonPackage rec {
+ pname = "mercantile";
+ version = lib.substring 0 7 src.rev;
+ src = mercantile;
+
+ propagatedBuildInputs = [ click ];
+
+ checkInputs = [ pytest ];
+ checkPhase = "pytest";
+
+ meta = with lib; {
+ description = mercantile.description;
+ homepage = mercantile.homepage;
+ license = licenses.bsd3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}